Bug 1940649 - New CSV using ServiceAccount named "default" stuck in Pending during upgrade
Summary: New CSV using ServiceAccount named "default" stuck in Pending during upgrade
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.5
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.6.z
Assignee: Ben Luddy
QA Contact: Bruno Andrade
URL:
Whiteboard:
Depends On: 1936707
Blocks: 1940651
TreeView+ depends on / blocked
 
Reported: 2021-03-18 19:12 UTC by Ben Luddy
Modified: 2021-04-20 19:27 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1936707
: 1940651 (view as bug list)
Environment:
Last Closed: 2021-04-20 19:27:22 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github operator-framework operator-lifecycle-manager pull 2051 0 None open [release-4.6] Bug 1940649: Allow non-CSV-owned ServiceAccounts to satisfy CSV requirements. 2021-03-22 13:50:00 UTC
Red Hat Product Errata RHBA-2021:1153 0 None None None 2021-04-20 19:27:39 UTC

Comment 2 Bruno Andrade 2021-03-26 04:08:25 UTC
Looks good, steps used to reproduce it:

OLM version: 0.16.1
git commit: 58918fa71fca6874c7bd884ce541de0ecf1ea411

1) Create the namespace and the default service account is present

oc get sa default -n test-operators -o yaml 
apiVersion: v1
imagePullSecrets:
- name: default-dockercfg-jl745
kind: ServiceAccount
metadata:
  creationTimestamp: "2021-03-26T04:05:49Z"
  name: default
  namespace: test-operators
  resourceVersion: "46938"
  selfLink: /api/v1/namespaces/test-operators/serviceaccounts/default
  uid: dac31d3f-9e96-457e-a547-d4cc6f300b59
secrets:
- name: default-token-v8vh6
- name: default-dockercfg-jl745

2) Create the operator group
3) Create the CSV as oriented
4) Check if CSV installation succeeds.
  phase: Succeeded
  reason: InstallSucceeded
  requirementStatus:
  - group: ""
    kind: ServiceAccount
    message: ""
    name: default
    status: Present
    version: v1

Comment 8 errata-xmlrpc 2021-04-20 19:27:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6.25 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:1153


Note You need to log in before you can comment on or make changes to this bug.