Bug 19408 - ReadmeName isn't working
Summary: ReadmeName isn't working
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: apache (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact: Dale Lovelace
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-19 23:21 UTC by compwiz
Modified: 2007-04-18 16:29 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-21 10:45:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description compwiz 2000-10-19 23:21:28 UTC
The directive "ReadmeName README" is supposed to print the file 'README' at
the end of a directory listing. However, this doesn't work.

Comment 1 Nalin Dahyabhai 2000-10-20 21:43:10 UTC
Apparently this changed in 1.3.6.  Unless you have the mod_mime_magic module
enabled (which is not the case by default), Apache cannot determine the type of
a file named "README", and unless it can determine that its type is
"text/plain", "text/html", or another "text" type, it will ignore it when
generating directory indexes.

Tests show that either enabling the mod_mime_magic module or changing the
ReadmeName to something which can be guessed by mod_mime (like "README.txt")
works, but the core should be assigning the DefaultType ot "text/plain" to it.

Comment 2 Joe Orton 2004-09-21 10:45:50 UTC
Thanks for the report.  This is a mass bug update; since this release
of Red Hat Linux is no longer supported, please either:

a) try and reproduce the bug with a supported version of Red Hat
Enterprise Linux or Fedora Core, and re-open this bug as appropriate
after changing the Product field, or,

b) if relevant, try and reproduce this bug using the current version
of the upstream package, and report the bug upstream.



Note You need to log in before you can comment on or make changes to this bug.