Bug 194081 - anacron with cron spam root mailbox
anacron with cron spam root mailbox
Status: CLOSED DUPLICATE of bug 191410
Product: Fedora
Classification: Fedora
Component: anacron (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-05 13:40 EDT by Michal Jaegermann
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-05 13:56:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2006-06-05 13:40:42 EDT
Description of problem:

If timing is "right" then whomever gets root messages is 
subjected to messages like "anacron: Cannot run - another
anacron process is already running.: Resource deadlock avoided".
Fine and dandy but really usefulness of such information
is not very high.  This one gets from "Anacron job 'cron.daily'"
and 'cron.weekly' and 'cron.monthly'.

If there is no better way to shut that down then can we
have at least '>/dev/null 2>&1' in corresponding scripts?
Or drop with grep these "deadlock" message to a bitbucket
if /dev/null treatment could remove something really important?

Another option would be a guard in those scripts in this style:

pgrep anacron >/dev/null || anacron -u cron.daily

I guess that an assumption that 'procps' package is present is
quite safe or "type -p pgrep" can be tested before we are trying
to use it. Say

[ "$(type -p pgrep)" ] && pgrep anacron >/dev/null && exit 1
anacron -u cron.daily

or something similar.

Version-Release number of selected component (if applicable):
anacron-2.3-38.FC6
Comment 1 Jason Vas Dias 2006-06-05 13:56:34 EDT

*** This bug has been marked as a duplicate of 191410 ***

Note You need to log in before you can comment on or make changes to this bug.