Bug 1940815 - [FFU OSP13 to 16.1.4] During FFU in overcloud enabled, nova scheduler failed to start after the upgrade due to RamFilter, DiskFilter got removed in 16
Summary: [FFU OSP13 to 16.1.4] During FFU in overcloud enabled, nova scheduler failed ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-validations
Version: 16.1 (Train)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: z7
: 16.1 (Train on RHEL 8.2)
Assignee: David Vallee Delisle
QA Contact: nlevinki
URL:
Whiteboard:
Depends On:
Blocks: 1964986
TreeView+ depends on / blocked
 
Reported: 2021-03-19 09:29 UTC by Paras Babbar
Modified: 2021-12-09 20:18 UTC (History)
8 users (show)

Fixed In Version: openstack-tripleo-validations-11.3.2-1.20210715133307.4db92ba
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1964986 (view as bug list)
Environment:
Last Closed: 2021-12-09 20:18:11 UTC
Target Upstream Version: Train


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 789698 0 None MERGED Introducing the oslo_config_validator role 2021-07-12 11:04:33 UTC
OpenStack gerrit 799483 0 None MERGED Introducing the oslo_config_validator role 2022-01-27 15:49:46 UTC
Red Hat Issue Tracker OSP-274 0 None None None 2021-11-18 11:31:07 UTC
Red Hat Product Errata RHBA-2021:3762 0 None None None 2021-12-09 20:18:44 UTC

Description Paras Babbar 2021-03-19 09:29:20 UTC
Description of problem:
At the time of FFU upgrade if we have enabled RamFilter, DiskFilter in OSP13 and tried doing to upgrade to 16.1, the overcloud upgrade will failed as nova scheduler won't be able to start due to 

./nova-scheduler.log:2021-03-19 00:36:23.794 7 ERROR nova nova.exception.SchedulerHostFilterNotFound: Scheduler Host Filter RamFilter, DiskFilter could not be found.
./nova-scheduler.log:2021-03-19 00:36:23.794 7 ERROR nova

Version-Release number of selected component (if applicable):


How reproducible:
everytime

Steps to Reproduce:
1. deploy OSP13 With RamFilter, DiskFilter
2. run the FFU 
3. overcloud FFU controller failed 

Actual results:
FFU failed

Expected results:
FFU should pass

Additional info:

Comment 2 Martin Schuppert 2021-03-19 09:39:35 UTC
DiskFilter and RamFilter was removed in train, NovaSchedulerDefaultFilters in the environment file needs to be updated to remove those.

https://docs.openstack.org/releasenotes/nova/train.html#relnotes-20-0-0-stable-train-upgrade-notes "The CoreFilter, DiskFilter and RamFilter, which were deprecated in Stein (19.0.0), are now removed. "

This BZ should be used to track a tripleo-validations check for that.

Comment 24 errata-xmlrpc 2021-12-09 20:18:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (Red Hat OpenStack Platform 16.1.7 (Train) bug fix and enhancement advisory), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:3762


Note You need to log in before you can comment on or make changes to this bug.