Bug 194123 - Can't do multlib development correctly because of missing macros
Can't do multlib development correctly because of missing macros
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Panu Matilainen
:
Depends On:
Blocks: FC6Blocker
  Show dependency treegraph
 
Reported: 2006-06-05 17:12 EDT by Bill Nottingham
Modified: 2014-03-16 23:00 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-15 09:07:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2006-06-05 17:12:21 EDT
On any standard x86-64 box, you only have /usr/lib/{x86_64,noarch}-linux
directories, and only have macro files for those directories.

Hence, if you try and build i386 packages, you will get packages with
%{_lib} = lib64, %{_libdir} = /usr/lib64, etc.
Comment 1 Paul Nasrat 2006-06-26 15:21:11 EDT
If you rm -f /etc/rpm/platform and use setarch i386 rpmbuild does it work?
Comment 2 Bill Nottingham 2006-06-29 00:15:37 EDT
Appears to, at least from a quick check of /lib vs /lib64.
Comment 3 Jeff Johnson 2006-07-02 07:58:56 EDT
And what was in /etc/rpm/platform pray tell? "ia32e" is my guess ...
Comment 4 Bill Nottingham 2006-07-12 20:39:30 EDT
[notting@xenomorph ~]$ cat /etc/rpm/platform
x86_64-redhat-linux
Comment 5 Jeff Johnson 2006-07-13 12:11:56 EDT
Ok, my bad (although there's another closely reklated problem with multiple aliases like amd64 and i132e 
for x86_64).

Arch (as currently set within rpm using uname(2) or /etc/rpm/platfrom) is not the right variable to 
determine multilib build configuration.
Comment 6 Jeff Johnson 2006-08-06 17:48:29 EDT
This problem is likely fixed (by setting arch from --target) in rpm-4.4.7-0.15.

UPSTREAM
Comment 7 Hans de Goede 2006-10-27 04:17:12 EDT
Jeff,

Any chance you could isolate the patch from 4.4.7 and attach that here. Please
don't take this wrong:
1) I do not wish to get involved in the whole fork rpm or stick with upstream 
   discussion.
2) I would love to see Fedora jump to 4.4.7 since some of the new features I 
   could really use (I maintain 80+ packages in FE).
But:
3) I don't see the jump to 4.4.7 happening soon and would still like to see this
   fixed.

Thanks!
Comment 8 Jeff Johnson 2006-10-27 08:04:59 EDT
The patch to use --target is non-trivial and mired in legacy expectations of how
rpmbuild should be configured. E.g. setarch is not the right approach, consider
non-linux functionality (which I have to accomodate even if you don't).

I don't wish to be involved with Fedora fork-or-jbj discussions either; I feel your pain.

I don't see the "jump" to 4.4.7 happening at all. Various people will talk, wring their
hands about how big an asshole I am, and do nothing.
Comment 9 Jeff Johnson 2006-10-27 12:29:22 EDT
FWIW, the patches necessary to implement setting rpm's conception
of arch from --target were posted to <rpm-devel@lists.dulug.duke.edu>
in August 2006 with a request for comments. Some of the comments remain
to be satisfied.
Comment 10 Red Hat Bugzilla 2007-08-21 01:24:10 EDT
User pnasrat@redhat.com's account has been closed
Comment 11 Panu Matilainen 2007-08-22 02:31:43 EDT
Reassigning to owner after bugzilla made a mess, sorry about the noise...
Comment 12 Panu Matilainen 2008-01-15 09:07:25 EST
rpm 4.4.2.2-13 in rawhide now includes the x86 arch macros on x86_64. That
doesn't fix much by itself, the issue is, um, tangled...

Note You need to log in before you can comment on or make changes to this bug.