Bug 1941234 - Dependency on python-importlib-metadata >= 1 at EPEL 8
Summary: Dependency on python-importlib-metadata >= 1 at EPEL 8
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: python-keyring
Version: epel8
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Christopher Tubbs
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-03-21 00:34 UTC by Robert Scheck
Modified: 2022-04-01 16:43 UTC (History)
7 users (show)

Fixed In Version: python-keyring-21.5.0-2.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-04-01 16:43:24 UTC
Type: Bug


Attachments (Terms of Use)

Description Robert Scheck 2021-03-21 00:34:07 UTC
Description of problem:
What's the situation with the dependency on python-importlib-metadata >= 1 at EPEL 8? Is it really required? As of writing, it needs python-importlib-metadata >= 1 (older versions of python-keyring don't), while all branches are shipping a python-importlib-metadata 0.x version...

Version-Release number of selected component (if applicable):
python-keyring-21.5.0-1.el8

Additional info:
https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-dfe69c0284

Comment 1 Christopher Tubbs 2021-03-22 03:39:48 UTC
It looks like it was dropped in F32 in https://src.fedoraproject.org/rpms/python-keyring/c/12cd719fb2074682cee5df00b736d7b5d9ad2897 and then dropped for RHEL9 and ELN in https://src.fedoraproject.org/rpms/python-keyring/c/925e92808ff725314308c7de211721259e44f0ae

`rpm -q --requires` on the epel8 package includes:

python3-importlib-metadata
python3.6dist(importlib-metadata)

If there's a `>= 1` requirement, I don't think it's coming from this package, though. I don't see that in this output or in the spec file.

I do not use EPEL8 and only built the package for that branch because it was requested, so I do not know what is required there. If somebody knows more about the situation with EPEL8, I'd be happy to take suggestions or pull requests, but I'm not really interested in doing much work for that branch, since I don't use it.

Comment 2 Ben Beasley 2022-03-22 13:06:08 UTC
I just looked into this.

The current stable version in EPEL8 seems to be python3-keyring-21.3.1-1.el8, and it installs fine (with python3-importlib-metadata <1). The version in dist-git is python3-keyring-21.5.0-1.el8, as referenced in this bug.

I did a local mockbuild and confirmed:

> $ rpm -q --requires -p results_python-keyring/21.5.0/1.el8/python3-keyring-21.5.0-1.el8.noarch.rpm 
/usr/bin/python3.6
> python(abi) = 3.6
> python3-SecretStorage
> python3-importlib-metadata
> python3.6dist(importlib-metadata) >= 1
> […]

The “>= 1” is coming from setup.cfg in this version. It was added upstream in [1] to fix an issue[2] that happened when importlib-metadata was 0.9 or older. Presumably 1.0 was picked becasuse it was a recent milestone release at the time.

The changelogs[3] for importlib-metadata indicate that the major change from 0.23 to 1.0.0 was removing a compatibility shim for beta releases of Python. The other change was for better coexistence with the stdlib implementation, which only matters for versions of Python that have one. Based on that, there’s no reason to believe that version 0.23 won’t work.

[1] https://github.com/jaraco/keyring/commit/9ba71d6171f03352b8180258695e52f7b63cf2de
[2] https://github.com/jaraco/keyring/issues/466
[3] https://importlib-metadata.readthedocs.io/en/latest/history.html#v1-0-0

Comment 4 Fedora Update System 2022-03-23 14:53:50 UTC
FEDORA-EPEL-2022-91548edc87 has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-91548edc87

Comment 5 Fedora Update System 2022-03-24 15:50:41 UTC
FEDORA-EPEL-2022-91548edc87 has been pushed to the Fedora EPEL 8 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-91548edc87

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 6 Fedora Update System 2022-04-01 16:43:24 UTC
FEDORA-EPEL-2022-91548edc87 has been pushed to the Fedora EPEL 8 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.