Bug 1941507 - [RFE] Implement rotation mechanism for /var/log/ovirt-engine/host-deploy
Summary: [RFE] Implement rotation mechanism for /var/log/ovirt-engine/host-deploy
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.4.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ovirt-4.4.8
: ---
Assignee: Dana
QA Contact: Pavol Brilla
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-03-22 09:34 UTC by Roman Hodain
Modified: 2021-09-08 14:12 UTC (History)
5 users (show)

Fixed In Version: ovirt-engine-4.4.8.1
Doc Type: Enhancement
Doc Text:
Previously, log files would use too much disk space because the operation runs frequently. The current release fixes this issue by implementing the logrotate feature. With this feature, logs will be rotated monthly or daily with only one archive file being retained. Host deployment, enrollment certificate, host upgrade, ova, brick setup and db-manual logs are rotated monthly. Check for update logs are rotated daily. Compressed files will be removed for update logs 24 hours from the time of creation, brick setup logs will be removed 30 days from the time of creation, and all other logs will be removed 30 days from the last metadata change.
Clone Of:
Environment:
Last Closed: 2021-09-08 14:12:04 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2021:3460 0 None None None 2021-09-08 14:12:16 UTC
oVirt gerrit 115286 0 master MERGED engine: implement logrotate machanism for host deploy 2021-07-15 04:31:52 UTC

Description Roman Hodain 2021-03-22 09:34:48 UTC
Description of problem:
/var/log/ovirt-engine/host-deploy is not used only for host deployment, but also for other tasks like checking whether there are any updates available for the hypervisors. These operations are very frequent and cause the directory to grow extensively. 

Version-Release number of selected component (if applicable):
RHV 4.4

How reproducible:
100%

Steps to Reproduce:
1. Check the directory size weekly 

Actual results:
In bigger environment 100+ hosts the directory can grow over 500MB weekly and generate over 500 files weekly. This also causes an issue when collecting data via log collecter as the entire directory is included in the log collector.

Expected results:
A retention policy is implemented.

Comment 1 RHEL Program Management 2021-06-22 03:33:25 UTC
The documentation text flag should only be set after 'doc text' field is provided. Please provide the documentation text and set the flag to '?' again.

Comment 2 Martin Perina 2021-06-30 13:30:58 UTC
Asking for an exception for 4.4.7 release, because currently logrotate don't remove log files with timestamp in their names, so disk space on oVirt engine can be exhausted soon on large scale setups.

Comment 3 Dana 2021-07-21 09:02:10 UTC
Logs are rotated as follows:
- host deploy, enroll certificates, host upgrade, ova, brick setup and db-manual logs are rotated monthly, and one archived file is kept.
- check for updates is rotated daily, and one archived file is kept.

Compressed files are removed as follows:
- host deploy, enroll certificates, host upgrade and ova logs are removed 30 days from when their metadata was changed.
- check for updates is removed one day from its creation time. 
- brick setup log is removed 30 days from its creation time

Comment 6 Pavol Brilla 2021-08-24 10:32:45 UTC
verified during week on 1 environment

Comment 11 errata-xmlrpc 2021-09-08 14:12:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (RHV Manager (ovirt-engine) [ovirt-4.4.8]), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:3460


Note You need to log in before you can comment on or make changes to this bug.