Bug 1941784 (CVE-2021-28971) - CVE-2021-28971 kernel: System crash in intel_pmu_drain_pebs_nhm in arch/x86/events/intel/ds.c
Summary: CVE-2021-28971 kernel: System crash in intel_pmu_drain_pebs_nhm in arch/x86/e...
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2021-28971
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1941785 1948343 1948344 1948345
Blocks: 1941786
TreeView+ depends on / blocked
 
Reported: 2021-03-22 19:02 UTC by Pedro Sampaio
Modified: 2022-05-17 09:37 UTC (History)
42 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
A flaw was found in the Linux kernel. On some Haswell CPUs, userspace applications (such as perf-fuzzer) can cause a system crash because the PEBS status in a PEBS record is mishandled.
Clone Of:
Environment:
Last Closed: 2021-11-09 20:22:42 UTC


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2021:4140 0 None None None 2021-11-09 17:22:01 UTC
Red Hat Product Errata RHSA-2021:4356 0 None None None 2021-11-09 18:24:26 UTC

Description Pedro Sampaio 2021-03-22 19:02:30 UTC
In intel_pmu_drain_pebs_nhm in arch/x86/events/intel/ds.c in the Linux kernel on some Haswell CPUs, userspace applications using performance counters can cause a system crash because the PEBS status in a PEBS record is mishandled and not reset correctly.

Upstream patch:

https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=d88d05a9e0b6d9356e97129d4ff9942d765f46ea

Comment 1 Pedro Sampaio 2021-03-22 19:03:09 UTC
Created kernel tracking bugs for this issue:

Affects: fedora-all [bug 1941785]

Comment 9 Wade Mealing 2021-04-12 01:55:57 UTC
Mitigation:

Mitigation for this issue is either not available or the currently available options does not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.

Comment 18 errata-xmlrpc 2021-11-09 17:21:58 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8

Via RHSA-2021:4140 https://access.redhat.com/errata/RHSA-2021:4140

Comment 19 errata-xmlrpc 2021-11-09 18:24:22 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8

Via RHSA-2021:4356 https://access.redhat.com/errata/RHSA-2021:4356

Comment 20 Product Security DevOps Team 2021-11-09 20:22:38 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):

https://access.redhat.com/security/cve/cve-2021-28971


Note You need to log in before you can comment on or make changes to this bug.