Bug 1942023 - [RFE] host-deploy: Allow adding non-CentOS hosts based on RHEL
Summary: [RFE] host-deploy: Allow adding non-CentOS hosts based on RHEL
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: ovirt-host-deploy-ansible
Version: future
Hardware: Unspecified
OS: Unspecified
low
low vote
Target Milestone: ovirt-4.4.7
: 4.4.7
Assignee: Yedidyah Bar David
QA Contact: Nikolai Sednev
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-03-23 13:09 UTC by Andrew Lukoshko
Modified: 2021-07-06 07:28 UTC (History)
3 users (show)

Fixed In Version: ovirt-engine-4.4.7
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-07-06 07:28:24 UTC
oVirt Team: Infra
mperina: ovirt-4.4?
pm-rhel: planning_ack?
mperina: devel_ack+
pm-rhel: testing_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 113817 0 master ABANDONED engine: add AlmaLinux support to ansible playbooks 2021-05-17 13:04:24 UTC
oVirt gerrit 114663 0 master MERGED packaging: Support any rhel- or fedora-like distribution 2021-05-18 11:10:35 UTC

Description Andrew Lukoshko 2021-03-23 13:09:19 UTC
Description of problem:
ovirt hosted engine installation fails on AlmaLinux (https://almalinux.org)

Version-Release number of selected component (if applicable):
any

How reproducible:
100%

Steps to Reproduce:
1. Install AlmaLinux
2. Follow ovirt installation instructions here https://www.ovirt.org/download/

Actual results:
"2021-03-06 19:42:30 OMST - fatal: [node02.locdomain.local]: FAILED! => {"changed": false, "module_stderr": "/bin/sh: /usr/bin/python2: No such file or directory\n", "module_stdout": "", "msg": "The module failed to execute correctly, you probably need to set the interpreter.\nSee stdout/stderr for the exact error", "rc": 127}" 

Expected results:
ovirt hosted engine installed

Additional info:
https://gerrit.ovirt.org/c/ovirt-engine/+/113817

Comment 1 RHEL Program Management 2021-03-23 15:01:17 UTC
The documentation text flag should only be set after 'doc text' field is provided. Please provide the documentation text and set the flag to '?' again.

Comment 3 Yedidyah Bar David 2021-06-17 05:59:25 UTC
QE: It's enough that you do sanity testing for this bug.

Andrew, the requester of this bug, already verified that the linked patch is enough for adding an Alma Linux host to the engine.

Generally speaking, the patch should be enough for adding a host running any RHEL8 rebuild. If someone tries this and fails, please open another bug, with more details.

Comment 4 Nikolai Sednev 2021-06-17 07:38:08 UTC
Is it to verify that Almalinux can be added as additional host to the HE environment, either as additional ha-host or none ha-host?
The description says that "ovirt hosted engine installation fails on AlmaLinux", this is something different, its about HE deployment over Almalinux and this part is confusing, please clear what should be tested here.

Comment 5 Yedidyah Bar David 2021-06-17 08:21:31 UTC
I didn't look at all at hosted-engine. It might as well be that the patch was enough also for that. You are welcome to try. Current bug is on host-deploy, and that's what the patch fixed.

Comment 6 Nikolai Sednev 2021-06-24 08:42:46 UTC
This bug will be tested by automation tier 1, thus moving to verified.

Functionality of adding Almalinux host to RHV engine is required from customer's input.

Comment 7 Andrew Lukoshko 2021-06-29 08:47:33 UTC
Hi!
This bug is about adding AlmaLinux host to ovirt-engine.
Issue happens while deploying HE but it's actually general issue and there is no difference when to add host - during HE deploy or later, it will fail.

Comment 8 Sandro Bonazzola 2021-07-06 07:28:24 UTC
This bugzilla is included in oVirt 4.4.7 release, published on July 6th 2021.

Since the problem described in this bug report should be resolved in oVirt 4.4.7 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.