Bug 1942160 - Operand page shows a 404:Not Found error for OpenShift GitOps Operator
Summary: Operand page shows a 404:Not Found error for OpenShift GitOps Operator
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.7
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.7.z
Assignee: Chetan
QA Contact: spathak@redhat.com
URL:
Whiteboard:
Depends On: 1937929
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-03-23 18:56 UTC by OpenShift BugZilla Robot
Modified: 2021-06-29 04:20 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-06-29 04:19:47 UTC
Target Upstream Version:


Attachments (Terms of Use)
Operand page :No error found for OpenShift GitOps Operator (77.48 KB, image/png)
2021-06-20 18:15 UTC, spathak@redhat.com
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 8450 0 None open [release-4.7] Bug 1942160: Update the scope of GitOpsService resource 2021-03-23 18:57:33 UTC
Red Hat Product Errata RHBA-2021:2502 0 None None None 2021-06-29 04:20:13 UTC

Description OpenShift BugZilla Robot 2021-03-23 18:56:10 UTC
+++ This bug was initially created as a clone of Bug #1937929 +++

Created attachment 1762731 [details]
Screenshot of the 404 error in the GItOpsService operand page

Description of problem:
On installation of OpenShift GitOps operator, the Operator UI shows a 404: Not Found error in the GitOpsService operand page

Version-Release number of selected component (if applicable): OCP 4.7


How reproducible:


Steps to Reproduce:
1. Install OpenShift GitOps Operator from Operator Hub
2. Navigate to installed operators > GitOps Operator > GitOpsServices operand tab
3. Observe the 404: Not Found error

Actual results:

GitOpsService Operand page shows a 404:Not Found error

Expected results:

GitOpsService Operand page should display the list of GitOpsService operands

--- Additional comment from cbanavik@redhat.com on 2021-03-15 12:34:08 UTC ---

PR to fix this bug: https://github.com/openshift/console/pull/8379

--- Additional comment from cjerolim@redhat.com on 2021-03-23 10:08:24 UTC ---

Verified on 4.8.0-0.nightly-2021-03-22-064955

Could verify that also that it also/still exist on 4.7.3

@cbanavik@redhat.com should we backport this small fix? It's only low severity.

--- Additional comment from cbanavik@redhat.com on 2021-03-23 15:51:20 UTC ---

@

--- Additional comment from cbanavik@redhat.com on 2021-03-23 16:02:49 UTC ---

Hi @cjerolim@redhat.com,  , 

Thanks for verifying this. It would be better if we can get it backported to 4.7 since OpenShift GitOps will be going GA with 4.7

Comment 2 spathak@redhat.com 2021-06-20 18:15:08 UTC
Created attachment 1792537 [details]
Operand page :No error found for OpenShift GitOps Operator

Comment 3 spathak@redhat.com 2021-06-20 18:30:19 UTC
Verified on build version: 4.7.0-0.nightly-2021-06-17-224843
Browser: Google Chrome 89

Comment 6 errata-xmlrpc 2021-06-29 04:19:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.7.18 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:2502


Note You need to log in before you can comment on or make changes to this bug.