Bug 194233 - Unable to umount cifs share
Unable to umount cifs share
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Simo Sorce
David Lawrence
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-06 10:33 EDT by John Horne
Modified: 2008-04-04 09:23 EDT (History)
4 users (show)

See Also:
Fixed In Version: samba-client-3.0.28a-0.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-04 09:23:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of 'strace -Ff umount /root/gridshare' (12.29 KB, text/plain)
2006-06-06 10:37 EDT, John Horne
no flags Details

  None (edit)
Description John Horne 2006-06-06 10:33:38 EDT
Description of problem:
Trying to unmount a cifs share gives error that it only unmounts cifs filesystems.

Version-Release number of selected component (if applicable):
samba-client-3.0.22-1.fc5

How reproducible:
Every time.

Steps to Reproduce:
1. Mount a cifs share on to the system.
2. Try to umount the share.
3.
  
Actual results:
Error displayed:
  This utility only unmounts cifs filesystems.
  This utility only unmounts cifs filesystems.

Expected results:
No error messages. The share should unmount.

Additional info:
The mount command shows:
   //ilsabc.uopnet.plymouth.ac.uk/Grid on /root/gridshare type cifs 
   (rw,mand,noexec,nosuid,nodev)

The umount command command gives:
   umount /root/gridshare
   This utility only unmounts cifs filesystems.
   This utility only unmounts cifs filesystems.

Not sure why it displays it twice.

We cannot now unmount this share at all.

SELinux is disabled on the system (I read that that may be a cause, but not in
this case).



John.
Comment 1 John Horne 2006-06-06 10:37:06 EDT
Created attachment 130608 [details]
Output of 'strace -Ff umount /root/gridshare'

I ran the strace command in case the output was of any help.
Comment 2 Bug Zapper 2008-04-03 23:03:01 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 3 John Horne 2008-04-04 09:23:09 EDT
I have tried this on a different server running Fedora 8 (using
samba-client-3.0.28a-0.fc8). Unmounting the cifs partition gives no error. As
such I think we can close this call as fixed. (Unfortunately the original server
is still running FC5, but hopefully that will change over the next few months.)


Many thanks,

John.

Note You need to log in before you can comment on or make changes to this bug.