RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Bug 1942574 - RHEL 8 kickstart text mode installation halts when just --encrypted is mentioned without --passphrase
Summary: RHEL 8 kickstart text mode installation halts when just --encrypted is mentio...
Keywords:
Status: CLOSED DUPLICATE of bug 2029101
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: anaconda
Version: 8.3
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Anaconda Maintenance Team
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-03-24 14:48 UTC by Alena
Modified: 2022-10-03 12:20 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-10-03 12:20:20 UTC
Type: Bug
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)

Description Alena 2021-03-24 14:48:50 UTC
Description of problem:

When RHEL 8 is kickstarted in text mode using the following partitioning, it fails with unfinished Disk configuration (Error checking storage configuration) error and would not prompt for luks password as RHEL 7 does graphical installation

~~~~~~~~~~~~~~~~~~~~~~~~
# Use graphical install
graphical
[...]
# Disk partitioning information
part /boot --fstype="ext4" --size=500
part /boot/eft --fstype="efi" --size=500
part swap --fstype="swap" --size=4096
part pv.01 --fstype="lvmpv" --size=1 --grow --encrypted
volgroup vg pv.01
[...]
~~~~~~~~~~~~~~~~~~~~~~~~~

When '--passphrase' is added the installation will complete.

Version-Release number of selected component (if applicable):

RHEL 8.3

How reproducible:

Always when '--passphrase' is not used

Steps to Reproduce:

1. Use the partitioning mentioned above and start the installation in graphical.

2. See error

Actual results:

Anaconda installer does not prompt user to enter passphrase.

See the below error in anaconda logs

08:10:14,080 DEBUG anaconda: Run sanity check verify_luks_devices_have_key.
08:10:14,080 DEBUG anaconda: Found sanity error: LUKS device vda3 has no encryption key
08:10:14,080 DEBUG anaconda: Storage check finished with failure(s).
08:10:14,081 ERR anaconda: LUKS device vda3 has no encryption key
08:10:14,081 INFO anaconda: Thread Done: AnaCheckStorageThread (xxxxxxxxxxxx)
08:10:14,202 INFO anaconda: spoke is ready: StorageSpoke
[...]
08:10:21,441 DEBUG anaconda: updated device_disks to [u'vda']
08:10:21,442 DEBUG anaconda: updated device_container_name to vg
08:10:21,442 DEBUG anaconda: updated device_container_raid_level to None
08:10:21,443 DEBUG anaconda: updated device_container_encrypted to True
08:10:21,443 DEBUG anaconda: updated device_container_size to 145.8 GiB
08:10:21,460 DEBUG anaconda: device_type_changed: 0 <gi.overrides.Gtk.TreeModelRow object at 0x7f456c0a07c50>


Expected results:

Anaconda installer prompts user for passphrase when it is not specified in the kickstart with '--encrypt'


Additional info:

Similar to bug Bug 1185466 which was filed in RHEL 7.

Comment 1 Jan Stodola 2022-10-03 12:20:20 UTC
This problem will be fixed in RHEL-8.7 via bug 2029101. I'm closing this one as a duplicate.

*** This bug has been marked as a duplicate of bug 2029101 ***


Note You need to log in before you can comment on or make changes to this bug.