Red Hat Satellite engineering is moving the tracking of its product development work on Satellite to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "Satellite project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs will be migrated starting at the end of May. If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "Satellite project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/SAT-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Bug 1942606 - Provisioning network bond using Kickstart default template fails as iface.attached_devices_identifiers outputs interfaces as a list instead of comma separated string required for --bondslaves option
Summary: Provisioning network bond using Kickstart default template fails as iface.att...
Keywords:
Status: CLOSED DUPLICATE of bug 1935088
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Provisioning Templates
Version: 6.8.0
Hardware: x86_64
OS: All
high
high
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Roman Plevka
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-03-24 15:49 UTC by Sam Wachira
Modified: 2021-05-07 07:49 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-05-07 07:49:06 UTC
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 31626 0 Normal Closed bondslaves in kickstart kernel options should be string not list 2021-03-24 16:12:02 UTC
Foreman Issue Tracker 32154 0 Normal Duplicate Error Kickstart value –bondslaves=[“eno1”, “eno2”] 2021-03-24 15:52:57 UTC

Description Sam Wachira 2021-03-24 15:49:27 UTC
Description of problem:
Provisioning a network bond using Kickstart default template fails as the variable {iface.attached_devices_identifiers} on line 146 of the template does not return interfaces in a comma separated string.
The --bondslaves option for creating the bond requires comma separated input.

Navigate to Hosts > Provisioning Templates > Kickstart default
~~~
144  # bond
145    if iface.bond? && rhel_compatible && os_major >= 6
146	network_options.push("--bondslaves=#{iface.attached_devices_identifiers}")
147	network_options.push("--bondopts=mode=#{iface.mode};#{iface.bond_options.tr(' ', ';')}")
148  end
~~~

Version-Release number of selected component (if applicable):
Satellite 6.8

How reproducible:
Fully

Steps to Reproduce:
1. Use Kickstart default template to provision host with a bonded network.

Actual results:
Network bond is not created as expected.

Expected results:
--bondslaves option should receive input as a comma separated string to create the network bond.

Additional info:
Foreman issue is fixed already.
(https://projects.theforeman.org/issues/31626)

Commit
(https://github.com/theforeman/foreman/commit/25dfbb3830a58878e032868d862ea90116597353#diff-7755c8fb296da617f75e4c6e39445726b059bc099dde6151bbe5bf468dcb9f20)

Comment 3 Lukas Zapletal 2021-05-07 07:49:06 UTC
I am gonna close this one as DUPE.

*** This bug has been marked as a duplicate of bug 1935088 ***


Note You need to log in before you can comment on or make changes to this bug.