Bug 194295 - GDM: Xserver not found: /usr/X11R6/bin/X
GDM: Xserver not found: /usr/X11R6/bin/X
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
5
All Linux
medium Severity urgent
: ---
: ---
Assigned To: Ray Strode [halfline]
Mike McLean
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-06 18:02 EDT by petrosyan
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version: gdm-2.14.8-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-16 18:59:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description petrosyan 2006-06-06 18:02:56 EDT
Description of problem:
After upgrading to the latest gdm from Fedora Core updates it stopped working.

Version-Release number of selected component (if applicable):
gdm-2.14.4-1.fc5.1

How reproducible:
Always

Steps to Reproduce:
1. Upgrade to the latest gdm-2.14.4-1.fc5.1 from Fedora Core updates.
2. Log out of GNOME.
  
Actual results:
gdm fails and gives the following error message:
GDM: Xserver not found: /usr/X11R6/bin/X :0 -audit 0 -auth /var/gdm/:0.Xauth
-nolisten tcp vt7
Error: Command could not be executed!
Please install the X server or correct GDM configuration and restart GDM.

Expected results:
It should work.
Comment 1 sangu 2006-06-06 21:16:50 EDT
The same problme happens in gdm-1:2.15.3-4 (rawhide 20060606)
Comment 2 petrosyan 2006-06-06 21:31:45 EDT
it started to work somehow.
Comment 3 Dan Williams 2006-06-07 11:32:44 EDT
Updating today (Jun 7) to the gdm built yesterday (gdm-2.15.3-5) makes it break
again.  I had to fix my /usr/share/gdm/defaults.conf to get stuff working.  Same
path issues, /usr/share/gdm/defaults.conf had paths of /usr/X11R6/bin again.
Comment 4 Dan Williams 2006-06-07 11:34:05 EDT
Looks like Jeremy may have fixed this today:

+%ifnarch s390 s390x
+BuildRequires: xorg-x11-server-Xorg
+%endif

+* Wed Jun  7 2006 Jeremy Katz <katzj@redhat.com> - 1:2.15.3-6
+- buildrequire the server so that we get the path right in the config file
Comment 5 Fedora Update System 2006-06-07 19:40:32 EDT
gdm-2.14.4-1.fc5.3 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 6 petrosyan 2006-06-16 18:58:31 EDT
this bug has been fixed in gdm-2.14.8-1

Note You need to log in before you can comment on or make changes to this bug.