Bug 194303 - Error: Missing Dependency: libXaw.so.7
Error: Missing Dependency: libXaw.so.7
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libXaw (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-06 22:18 EDT by sangu
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-07 03:05:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sangu 2006-06-06 22:18:42 EDT
Description of problem:
Installing libXaw-1.0.2-2.i386.rpm with yum,
[...]
Error: Missing Dependency: libXaw.so.7 is needed by package xorg-x11-xkb-utils
Error: Missing Dependency: libXaw.so.7 is needed by package xorg-x11-server-utils
Error: Missing Dependency: libXaw.so.7 is needed by package xterm
Error: Missing Dependency: libXaw.so.7 is needed by package xorg-x11-utils
Error: Missing Dependency: libXaw.so.7 is needed by package xorg-x11-apps

$ rpm -qp --provides  libXaw-1.0.2-2.i386.rpm
libXaw6.so.6
libXaw7.so.7
libXaw = 1.0.2-2

But
$ rpm -qpl libXaw-1.0.2-2.i386.rpm | grep libXaw.so.7
/usr/lib/libXaw.so.7

Version-Release number of selected component (if applicable):
1.0.2-2

How reproducible:
always

Steps to Reproduce:
1. $yum update libXaw
2.
3.
  
Actual results:


Expected results:


Additional info:
$ rpm -q --provides libXaw-1.0.2-1
libXaw.so.6
libXaw.so.7
libXaw = 1.0.2-1
Comment 1 Mike A. Harris 2006-06-07 03:05:52 EDT
Numerous rpm packages have recently started failing to build, claiming that
XAW could not be found, even though the packages were installed correctly.
This was first reported to us in an xorg-x11-resutils bug, which ./configure
was unable to detect XAW being present.

Additionally, many people have experienced the error you are reporting
above, which is caused by the same problem.  Yesterday we investigated this,
and oddly enough, the problem was not reproduceable on rpmbuild builds,
nor in beehive.  It only occured when building using mock.

The library would build, and get packaged seemingly ok, but nothing could
find it after that.  The problem was tracked down by Bill Nottingham, who
determined that the libXaw sonames were being incorrectly generated.  He
further tracked the problem down to being a missing build dependency.

A new libXaw package has been built with:

BuildRequires: ed

This allows it to build correctly and get the right soname.  Assuming there
are no other hidden issues, all packages that require libXaw should be
buildable now, and the reported error above should vanish as well.

It is possible that all software which links to libXaw may need to be
recompiled, so if you encounter any problems, please attempt to recompile
the given application's src.rpm to see if that fixes it before reporting
a bug against that component.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.