Bug 1943263 - Only lo network interface starts
Summary: Only lo network interface starts
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: 33
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: systemd-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-03-25 16:58 UTC by Ulrich Drepper
Modified: 2021-05-27 01:04 UTC (History)
11 users (show)

Fixed In Version: systemd-246.14-1.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-05-27 01:04:22 UTC
Type: Bug


Attachments (Terms of Use)
ip a after booting (486 bytes, text/plain)
2021-03-26 10:00 UTC, Ulrich Drepper
no flags Details
ip a after systemd-networkd restart (818 bytes, text/plain)
2021-03-26 10:01 UTC, Ulrich Drepper
no flags Details
networkctl output after booting (1.66 KB, text/plain)
2021-03-26 10:02 UTC, Ulrich Drepper
no flags Details
networkctl output after networkd restart (1.99 KB, text/plain)
2021-03-26 10:03 UTC, Ulrich Drepper
no flags Details

Description Ulrich Drepper 2021-03-25 16:58:01 UTC
Description of problem:
This is on a hosted KVM instance.  I cannot say more about the hosts KVM except that I think it is a widely used provider and that the bootup worked fine with Fedora 32, the original install.

After updating to Fedora 33 the eth0 interface does not come up anymore.  systemctl shows that systemd-entworkd.socket is waiting (or something like this, I only have a webconsole available which does not provide copy&paste).

Once I run
   systemctl restart systemd-networkd
after logging in to the console everything is fine.

The only noteworthy detail is that the system gets a routable IPv6 address as well.

I updated the system to Fedora 34 meanwhile and the problem persists.

On request I can run more tests and provide more logs.


Version-Release number of selected component (if applicable):
246.10-1.fc33
248~rc4-2.fc34

How reproducible:
always for me

Steps to Reproduce:
1.install Fedora 32 in this KVM guest
2.update in place to Fedora 33
3.reboot

Actual results:
only lo interface running

Expected results:
all network interfaces running

Additional info:

Comment 1 Zbigniew Jędrzejewski-Szmek 2021-03-26 09:23:14 UTC
Is this using systemd-networkd or NetworkManager to configure the network?

Please at least paste 'ip a' and 'networkctl status "*"'. Full logs from the boot
would be useful too.

Comment 2 Ulrich Drepper 2021-03-26 10:00:06 UTC
Created attachment 1766560 [details]
ip a after booting

Comment 3 Ulrich Drepper 2021-03-26 10:01:23 UTC
Created attachment 1766562 [details]
ip a after systemd-networkd restart

After I ran 'systemctl restart systemd-networkd' from the console

Comment 4 Ulrich Drepper 2021-03-26 10:02:15 UTC
Created attachment 1766563 [details]
networkctl output after booting

Comment 5 Ulrich Drepper 2021-03-26 10:03:31 UTC
Created attachment 1766564 [details]
networkctl output after networkd restart

after the manual systemd-networkd restart

Comment 6 Ulrich Drepper 2021-03-26 10:04:45 UTC
(In reply to Zbigniew Jędrzejewski-Szmek from comment #1)
> Is this using systemd-networkd or NetworkManager to configure the network?
> 
> Please at least paste 'ip a' and 'networkctl status "*"'. Full logs from the
> boot
> would be useful too.

I provided the output of the commands.

It complains about DHCP but that service does work, I can immediately after the bootup reliably restart networkd.

Comment 7 Zbigniew Jędrzejewski-Szmek 2021-03-26 15:03:00 UTC
Oh, OK. So systemd-networkd is not running, most likely because it is not enabled. I guess we screwed
up the scriptlet to set enablement when the package was split out.

Comment 8 Ulrich Drepper 2021-03-26 15:08:40 UTC
(In reply to Zbigniew Jędrzejewski-Szmek from comment #7)
> Oh, OK. So systemd-networkd is not running, most likely because it is not
> enabled. I guess we screwed
> up the scriptlet to set enablement when the package was split out.

You're right, that's all that it is.

After I explicitly enable systemd-networkd it now works.

This should really be fixed, seems like a bad bug.

BTW, this is the server edition of Fedora, in case it makes a difference.  I updated my desktop machine back when from earlier Fedora versions to 33 and cannot recall any problem like that.  The desktop uses the desktop edition.

Comment 9 Ulrich Drepper 2021-03-27 07:08:14 UTC
(In reply to Ulrich Drepper from comment #8)
> This should really be fixed, seems like a bad bug.

I determined I had the same problem on another machine.  There, though, the IPv4 address was for some reason configured but not the IPv6 address.  The result were long connection times until the IPv6 connection timed out.

Comment 10 Ulrich Drepper 2021-03-28 06:49:10 UTC
(In reply to Ulrich Drepper from comment #9)
> I determined I had the same problem on another machine.  There, though, the
> IPv4 address was for some reason configured but not the IPv6 address.  The
> result were long connection times until the IPv6 connection timed out.

To give people more chances to discover this solution:

on yet another machine the network interfaces came up (IPv4 and IPv6) but systemd-resolved never remembered the non-standard settings it can derive from the DHCP requests.  I added special rules and only after enable systemd-networkd are they now remembered over a restart.

Comment 11 Fedora Update System 2021-03-31 09:18:41 UTC
FEDORA-2021-8595b30af3 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-8595b30af3

Comment 12 Fedora Update System 2021-04-01 02:04:10 UTC
FEDORA-2021-8595b30af3 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-8595b30af3`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-8595b30af3

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 13 Fedora Update System 2021-04-03 01:28:18 UTC
FEDORA-2021-8595b30af3 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 14 Fedora Update System 2021-05-15 20:55:51 UTC
FEDORA-2021-25202922d4 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2021-25202922d4

Comment 15 Fedora Update System 2021-05-16 03:02:38 UTC
FEDORA-2021-25202922d4 has been pushed to the Fedora 33 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-25202922d4`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-25202922d4

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 16 Fedora Update System 2021-05-27 01:04:22 UTC
FEDORA-2021-25202922d4 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.