Bug 194360 - rpmbuild deliberately runs unasked %configure macro
rpmbuild deliberately runs unasked %configure macro
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2006-06-07 10:44 EDT by Andrea Santilli
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-06-08 08:30:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
output of rpmbuild -ba specfile (49.93 KB, text/plain)
2006-06-07 10:44 EDT, Andrea Santilli
no flags Details

  None (edit)
Description Andrea Santilli 2006-06-07 10:44:46 EDT
Description of problem:
I was writing a spec file and i put ./configure in it instead of %configure
because of buffer overflow issues in the application.
Then i noticed rpmbuild runs first %configure , then ./configure which should be
impossible because i never put the %configure line in the .spec file.

So I tried recompiling other rpms and it runs %configure twice!

I'm adding the output of rpmbuild (notice that i run aclocal and autoconf on
purpose). This is the %build section:

aclocal --acdir=`sdl-config --prefix`/share/aclocal
# I had some buffer overflow in zsnes having it configured by the %configure script
make %{?_smp_mflags}
### end of %build section ###

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. add ./configure in the spec file instead of %configure
2. rpmbuild will runs %configure then ./configure
Comment 1 Andrea Santilli 2006-06-07 10:44:46 EDT
Created attachment 130682 [details]
output of rpmbuild -ba specfile
Comment 2 Jeff Johnson 2006-06-08 08:30:47 EDT
Macros are expanded everywhere, including comments.

Add a 2nd '%' escape to prevent expansion as in ' ... %%configure ...'

Note You need to log in before you can comment on or make changes to this bug.