Bug 194368 - Cups crashes with too many open files message
Cups crashes with too many open files message
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks: FC6Target
  Show dependency treegraph
 
Reported: 2006-06-07 11:42 EDT by Marcelo de Souza Sant Anna
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 1.2.1-1.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-20 06:11:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
a patch form cups.org that solve the reported problem (6.14 KB, patch)
2006-06-07 11:42 EDT, Marcelo de Souza Sant Anna
no flags Details | Diff

  None (edit)
Description Marcelo de Souza Sant Anna 2006-06-07 11:42:29 EDT
Created attachment 130685 [details]
a patch form cups.org that solve the reported problem
Comment 1 Marcelo de Souza Sant Anna 2006-06-07 11:42:29 EDT
Description of problem:
We have a Fedora Core 5 fully updated and running on a IBM Server (Netfinity
5500 PII 350 MHz 512MB RAM 40 GB RAID 5 array). The server is a File and Print
server only. It's running Samba (3.0.22) and CUPS (1.2.1) all stock RPM packages
from Fedora Core. CUPS runs smoothly most of time and we have noted no
performance bottlenecks (mean CPU load of 15%). It manages a total of 13
printers. We note the problem when users complain they can not print, because
there is no other strange symptom on server. In all events we find this message
on /var/log/cups/error_log:
 Unable to open "/dev/null" - Too many open files.
After that, CUPS crash and in order to fix the problem we have just to restart
the service (typing "service cups restart" on server's command prompt). It shows
a failed message on stopping, as expected, and an OK message on starting. After
that, all works fine until the next crash. The crashes happens day or night,
including weekends.


Version-Release number of selected component (if applicable):
1.2.1

How reproducible:
Just start cupsd and let users print for some time

Steps to Reproduce:
1.
2.
3.
  
Actual results:
After a some time (hours) cups crashes

Expected results:
Run without problems

Additional info:
We have already submitted this problem to cups.org (str1757). They discovered on
 a previous bug report (str1736) that`s due to a leak:
r5617 | mike | 2006-06-01 14:26:23 -0400 (Thu, 01 Jun 2006) | 12 lines



Fixed another file descriptor leak when printing raw files (STR

#1736)



scheduler/client.c:

    - cupsdSendCommand(): Don't open /dev/null, just pass -1 to

      cupsdStartProcess().



scheduler/job.c:

    - start_job(): Don't open /dev/null, just pass -1 to

      cupsdStartProcess().
I am attaching their patch to this problem
Comment 2 Tim Waugh 2006-06-08 06:54:55 EDT
Please try this test update:

  https://www.redhat.com/archives/fedora-test-list/2006-June/msg00081.html

You should be able to fetch it using this command, as root:

  yum --enablerepo=updates-testing update 'cups*'
Comment 3 Marcelo de Souza Sant Anna 2006-06-08 10:04:03 EDT
We have just installed the patch and it looks solved, because the number of open
files on dev/null for cups is 0 (zero). We will confirm that at the end of the
day. The patch was painless and no user has even noticed the change.
Comment 4 Marcelo de Souza Sant Anna 2006-06-08 12:23:50 EDT
The problem is definitively solved. The day has not finished, but the number of
open files on dev/null for cups remains 0. That's too different from the
previous situation. I think this fix is so important that I decided not to
postpone this confirmation.

Note You need to log in before you can comment on or make changes to this bug.