Bug 1944394 - Wrong Openshift node IP as kubelet setting VIP as node IP
Summary: Wrong Openshift node IP as kubelet setting VIP as node IP
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.7
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: 4.7.z
Assignee: Dan Winship
QA Contact: zhaozhanqi
URL:
Whiteboard:
: 1922812 (view as bug list)
Depends On: 1940939
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-03-29 20:43 UTC by OpenShift BugZilla Robot
Modified: 2021-07-30 08:34 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: kubelet picks wrong node IP, in unclear circumstances Consequence: Node becomes NotReady immediately after boot, until it is rebooted Fix: kubelet should reliably use the correct node IP Result: no NotReady nodes
Clone Of:
Environment:
Last Closed: 2021-04-20 18:52:39 UTC
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift machine-config-operator pull 2497 0 None open [release-4.7] Bug 1944394: Do "systemctl daemon-reload" after running "runtimecfg node-ip" 2021-04-01 16:01:04 UTC
Red Hat Product Errata RHBA-2021:1149 0 None None None 2021-04-20 18:52:59 UTC

Comment 3 zhaozhanqi 2021-04-12 12:18:44 UTC
Verified this bug on 4.7.0-0.nightly-2021-04-10-082109


[kni@provisionhost-0-0 ~]$ oc debug node/master-0-0 --image='quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:d7fdcdcc2754359ab49422d6f2f3e9612eb4332ed73d58705c5f086c343d3793'
Starting pod/master-0-0-debug ...
To use host binaries, run `chroot /host`
Pod IP: 192.168.123.109
If you don't see a command prompt, try pressing enter.
sh-4.4# chroot /host
sh-4.4# systemctl show --property=NeedDaemonReload kubelet
NeedDaemonReload=no

Comment 7 errata-xmlrpc 2021-04-20 18:52:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.7.7 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:1149

Comment 8 Dan Winship 2021-07-15 14:35:31 UTC
*** Bug 1922812 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.