Bug 1944482 - Bluetooth toggle on/off does not work
Summary: Bluetooth toggle on/off does not work
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: bluez
Version: 34
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Don Zickus
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-03-30 02:55 UTC by robert
Modified: 2021-07-31 19:13 UTC (History)
34 users (show)

Fixed In Version: bluez-5.58-2.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-05-20 01:12:12 UTC
Type: Bug


Attachments (Terms of Use)
The toggle button to trigger the problem (51.06 KB, image/png)
2021-03-30 02:55 UTC, robert
no flags Details
Screenshot two (38.04 KB, image/png)
2021-03-30 02:56 UTC, robert
no flags Details
Menu also contradictory (34.66 KB, image/png)
2021-03-30 02:56 UTC, robert
no flags Details


Links
System ID Private Priority Status Summary Last Updated
GNOME Gitlab GNOME/gnome-control-center - issues 1368 0 None None None 2021-05-17 21:36:12 UTC

Description robert 2021-03-30 02:55:19 UTC
Created attachment 1767520 [details]
The toggle button to trigger the problem

Description of problem:
If you turn off bluetooth, it is impossible to turn back on from the GUI. I have attached a screenshot of the toggle switch I'm talking about in Gnome settings

Version-Release number of selected component (if applicable):


How reproducible: I restarted my computer and tried the same steps and was able to reproduce after a fresh boot.


Steps to Reproduce:
1. Go to the bluetooth section in Gnome settings (see attachment)
2. Toggle Bluetooth off
3. Toggle Bluetooth on

Actual results:
See screenshot two. Basically the toggle switch is in the "on" state, but just below that it says "Bluetooth is turned off" which is contradictory. And also if you look at the menu in the top-right you'll notice it says "Bluetooth Off" but yet if you expand the toggle button there says "Turn Off" which seems to be related to the toggle switch that isn't working in the settings window.


Expected results:
When you turn bluetooth on, it should turn on.

Additional info:
I can successfully get bluetooth working again from the terminal by restarting the service like so:
systemctl restart bluetooth.service

Comment 1 robert 2021-03-30 02:56:12 UTC
Created attachment 1767521 [details]
Screenshot two

Comment 2 robert 2021-03-30 02:56:38 UTC
Created attachment 1767522 [details]
Menu also contradictory

Comment 3 Julius 2021-04-25 07:41:07 UTC
https://bugzilla.kernel.org/show_bug.cgi?id=211983 this seems to be a duplicate

Comment 4 Robin Lee 2021-04-26 03:53:16 UTC
I met the same issue on Lenovo ThinkBook 14s Yoga.

kernel-5.11.12-300.fc34.x86_64
gnome-bluetooth-3.34.5-1.fc34.x86_64

Comment 5 robert 2021-04-26 05:03:24 UTC
I am indeed using that card:
Network controller: Intel Corporation Wireless-AC 9560 [Jefferson Peak] (rev 10)

Comment 6 Benjamin Berg 2021-04-29 17:30:41 UTC
This might be a USB issue. On an X1C7, I ran into the problem that the USB device is simply gone.

On these machines, bluetooth is connected via USB. When the tpacpi_bluetooth_sw rfkill switch is changed, the underlying USB device is removed. In the error condition, it appears that the underlying USB device is never found again after being re-attached.

Usually, running:
 * rfkill block 0
   will make the USB device disappear (lsusb shows e.g. "8087:0026 Intel Corp.")
 * rfkill unblock 0
   will make the device reappear

However, on my X1C7 right now, the corresponding USB device is gone. It was alive at one point though:

[ 2246.627327] Bluetooth: hci0: Bootloader revision 0.1 build 42 week 52 2015
[ 2246.629498] Bluetooth: hci0: Device revision is 2
[ 2246.629500] Bluetooth: hci0: Secure boot is enabled
[ 2246.629501] Bluetooth: hci0: OTP lock is enabled
[ 2246.629502] Bluetooth: hci0: API lock is enabled
[ 2246.629502] Bluetooth: hci0: Debug lock is disabled
[ 2246.629503] Bluetooth: hci0: Minimum firmware build 1 week 10 2014
[ 2246.696264] Bluetooth: hci0: Found device firmware: intel/ibt-17-16-1.sfi
[ 2248.354460] Bluetooth: hci0: Waiting for firmware download to complete
[ 2248.355299] Bluetooth: hci0: Firmware loaded in 1694760 usecs
[ 2248.355312] Bluetooth: hci0: Waiting for device to boot
[ 2248.369282] Bluetooth: hci0: Device booted in 13653 usecs
[ 2248.370128] Bluetooth: hci0: Found Intel DDC parameters: intel/ibt-17-16-1.ddc
[ 2248.372293] Bluetooth: hci0: Applying Intel DDC parameters completed
[ 2248.375293] Bluetooth: hci0: Firmware revision 0.1 build 168 week 48 2020
[ 5704.505510] Bluetooth: hci0: HCI reset during shutdown failed

Comment 7 Benjamin Berg 2021-04-30 08:30:16 UTC
Hmm, not sure if this is interesting, but tried to dig up some logs:

[...]
Apr 27 20:11:57 ben-x1c7 pipewire-media-session[33641]: port 0x561f931ac6c0: set_io: Invalid argument
Apr 27 20:11:57 ben-x1c7 pipewire-media-session[33641]: port 0x561f931ac748: set_io: Invalid argument
Apr 27 20:11:57 ben-x1c7 pipewire[33631]: impl-core 0x55d780527a40: error -22 for resource 14: port_set_io failed: Invalid argument
Apr 27 20:11:57 ben-x1c7 pipewire[33631]: client-node 0x55d780866020: error seq:3290 -22 (port_set_io failed: Invalid argument)
Apr 27 20:11:57 ben-x1c7 pipewire[33631]: impl-core 0x55d780527a40: error -22 for resource 14: port_set_io failed: Invalid argument
Apr 27 20:11:57 ben-x1c7 pipewire[33631]: client-node 0x55d780866020: error seq:3291 -22 (port_set_io failed: Invalid argument)
Apr 27 20:11:58 ben-x1c7 kernel: input: Bose QC Earbuds (AVRCP) as /devices/virtual/input/input31

So, at 20:11:58 I had my earbuds connected (not working, because of pipewire)

Then, I must have disabled bluetooth:

Apr 27 20:12:04 ben-x1c7 systemd[1]: Starting Load/Save RF Kill Switch Status...
Apr 27 20:12:04 ben-x1c7 systemd[1]: Started Load/Save RF Kill Switch Status.

The port is disabled (which I think is expected when switching tpacpi_bluetooth_sw:

Apr 27 20:12:04 ben-x1c7 kernel: usb usb1-port10: disabled by hub (EMI?), re-enabling...
Apr 27 20:12:04 ben-x1c7 kernel: usb 1-10: USB disconnect, device number 5
Apr 27 20:12:04 ben-x1c7 kernel: Bluetooth: hci0: HCI reset during shutdown failed
Apr 27 20:12:04 ben-x1c7 obexd[34490]: disconnected: Transport got disconnected
[... complaints about BT device disappearing from userspace]
Apr 27 20:12:04 ben-x1c7 systemd[33301]: Stopped target Bluetooth.
Apr 27 20:12:04 ben-x1c7 systemd[1]: Stopped target Bluetooth.

Bluetooth fully disabled at this point.

Apr 27 20:12:05 ben-x1c7 kernel: usb usb1-port10: Cannot enable. Maybe the USB cable is bad?
Apr 27 20:12:06 ben-x1c7 kernel: usb usb1-port10: Cannot enable. Maybe the USB cable is bad?
Apr 27 20:12:06 ben-x1c7 kernel: usb usb1-port10: attempt power cycle

And I seem to enable bluetooth again:

Apr 27 20:12:06 ben-x1c7 kernel: usb 1-10: new low-speed USB device number 8 using xhci_hcd
Apr 27 20:12:06 ben-x1c7 kernel: usb 1-10: Device not responding to setup address.
Apr 27 20:12:07 ben-x1c7 kernel: usb 1-10: Device not responding to setup address.
Apr 27 20:12:07 ben-x1c7 kernel: usb 1-10: device not accepting address 8, error -71
Apr 27 20:12:07 ben-x1c7 kernel: usb 1-10: new low-speed USB device number 9 using xhci_hcd
Apr 27 20:12:07 ben-x1c7 kernel: usb 1-10: Device not responding to setup address.
Apr 27 20:12:07 ben-x1c7 kernel: usb 1-10: Device not responding to setup address.
Apr 27 20:12:07 ben-x1c7 kernel: usb 1-10: device not accepting address 9, error -71
Apr 27 20:12:07 ben-x1c7 kernel: usb usb1-port10: unable to enumerate USB device

Comment 8 Benjamin Berg 2021-04-30 08:40:21 UTC
Hmm, I think I hijacked this bug. The original bug is probably solved.

gnome-settings-daemon had issues reading(/writing) rfkill events. This is fixed in:
  gnome-settings-daemon-40.0.1-1.fc34.x86_64

I have the fixed gnome-settings-daemon, and my issue is quite different. i.e. the USB device is simply refusing to turn on again on my machine. I have not yet been able to reproduce it again (was trying on a different machine). I'll run some more tests to see if it I can reproduce it.

Comment 9 robert 2021-05-01 21:19:25 UTC
I just tested and not sure if I'm checking the version of that package right. First I did a dnf update (no updates) then I did:
dnf info gnome-settings-daemon

which tells me:
Installed Packages
Name         : gnome-settings-daemon
Version      : 40.0.1
Release      : 1.fc34
Architecture : x86_64
Size         : 5.6 M
Source       : gnome-settings-daemon-40.0.1-1.fc34.src.rpm
Repository   : @System
From repo    : updates

Assuming I'm checking the version correct, this problem is still happening.

I was able to see the device in the list from lsusb while in the state of the second screenshot:
Bus 001 Device 014: ID 8087:0aaa Intel Corp. Bluetooth 9460/9560 Jefferson Peak (JfP)

--------------------------------------------------------------------------------------------------------------

So I noticed something interesting while writing this up. I went back to the settings page to verify I was indeed in the state of screenshot two. And what I found was the bluetooth was on, I did not run any commands or toggle it back on. So I tried to "make it work" somehow in the UI and I managed to figure out a way, but my computer froze up and I had to do a hard reboot... I don't know what caused the freeze, it's not happening using these reproduction steps after a fresh boot, but just beware you may have to do a hard reboot too lol

Method to make bluetooth work again via UI (only ONE time):
Reproduction steps:
1. Just like before go to gnome settings on the bluetooth tab
2. Toggle Bluetooth off
3. Toggle Bluetooth on. At this point you should see screenshot two
4. Go to the Backgrounds tab
5. Go to the Bluetooth tab. Notice bluetooth devices show up in the list now. Weird
6. Toggle Bluetooth Off
7. Toggle Bluetooth On
8. Go to the Backgrounds tab
9. Bluetooth still off. At this point it doesn't seem like you can go to any tab to make it come back on.


I was able to restart bluetooth using
systemctl restart bluetooth.service

to get one more additional time with bluetooth on. After I turned it off this time I got this in dmesg output (cleared it before I started)
  987.252124] wlo1: deauthenticating from 10:c3:7b:51:3e:ec by local choice (Reason: 3=DEAUTH_LEAVING)
[  993.367104] wlo1: authenticate with 10:c3:7b:51:3e:ec
[  993.373079] wlo1: send auth to 10:c3:7b:51:3e:ec (try 1/3)
[  993.412585] wlo1: authenticated
[  993.413063] wlo1: associate with 10:c3:7b:51:3e:ec (try 1/3)
[  993.416336] wlo1: RX AssocResp from 10:c3:7b:51:3e:ec (capab=0x511 status=0 aid=2)
[  993.419265] wlo1: associated
[  993.486258] IPv6: ADDRCONF(NETDEV_CHANGE): wlo1: link becomes ready
[  993.504651] wlo1: Limiting TX power to 30 (30 - 0) dBm as advertised by 10:c3:7b:51:3e:ec
[ 1063.498766] Bluetooth: hci0: HCI reset during shutdown failed
[ 1152.401283] usb 1-14: reset full-speed USB device number 14 using xhci_hcd
[ 1152.528939] Bluetooth: hci0: unexpected event for opcode 0x0500
[ 1155.016075] Bluetooth: hci0: urb 0000000042d59c23 failed to resubmit (113)
[ 1195.230875] Bluetooth: hci0: urb 000000008927172a failed to resubmit (113)
[ 1214.766800] Bluetooth: hci0: urb 00000000ad6740a4 failed to resubmit (113)

I had to reboot my system to get bluetooth working again.


After rebooting I was able to get it working in UI using another method (whatever the reason, it is probably the same reason it works when I went to the background tab)
1. Open gnome bluetooth settings
2. Toggle bluetooth off
3. Toggle bluetooth on. We can see the bug at this point.
4. Don't change any tabs, simply close the window
5. Open settings. It brings you to the last open tab, which is Bluetooth. I can see Bluetooth is on.
6. Turn bluetooth off
7. Turn bluetooth on
8. close window
9. open settings again. Bluetooth is still off, even though the toggle switch "was" on when we closed the window. It is off at this point.
10. Turn bluetooth on
10. Go to Background tab
11. Go to bluetooth tab. Bluetooth still off
12. systemctl restart bluetooth
13. doesn't even turn on a second time

dmesg output:
[   26.045448] Bluetooth: RFCOMM TTY layer initialized
[   26.045453] Bluetooth: RFCOMM socket layer initialized
[   26.045484] Bluetooth: RFCOMM ver 1.11
[   31.818206] rfkill: input handler enabled
[   34.736330] logitech-hidpp-device 0003:046D:406F.0010: HID++ 4.5 device connected.
[   35.186180] rfkill: input handler disabled
[   88.968767] usb 1-14: reset full-speed USB device number 14 using xhci_hcd
[  104.327984] usb 1-14: device descriptor read/64, error -110
[  120.200793] usb 1-14: device descriptor read/64, error -110
[  120.416817] usb 1-14: reset full-speed USB device number 14 using xhci_hcd
[  136.073497] usb 1-14: device descriptor read/64, error -110
[  151.946338] usb 1-14: device descriptor read/64, error -110
[  152.162369] usb 1-14: reset full-speed USB device number 14 using xhci_hcd
[  157.464592] xhci_hcd 0000:00:14.0: Timeout while waiting for setup device command
[  163.096623] xhci_hcd 0000:00:14.0: Timeout while waiting for setup device command
[  163.304525] usb 1-14: device not accepting address 14, error -62
[  163.418575] usb 1-14: reset full-speed USB device number 14 using xhci_hcd
[  163.433323] Bluetooth: hci0: unexpected event for opcode 0x0500
[  165.747750] Bluetooth: hci0: urb 00000000375a0722 failed to resubmit (113)
[  403.376090] Bluetooth: hci0: urb 00000000ca175150 failed to resubmit (113)

Comment 10 robert 2021-05-02 14:26:20 UTC
When I was checking dmesg the other day I got this dump... I thought it was something else, but I can't seem to reproduce the issue. Looking closer at the message it mentions btusb_shutdown_intel, so I think this came from when my computer froze up and I had to reboot, not sure if it's helpful or not.

[25125.960620] ------------[ cut here ]------------
[25125.960627] kernel BUG at mm/slub.c:305!
[25125.960644] invalid opcode: 0000 [#1] SMP PTI
[25125.960653] CPU: 8 PID: 3334 Comm: gsd-rfkill Tainted: G          I       5.11.16-300.fc34.x86_64 #1
[25125.960662] Hardware name: ASUS System Product Name/ROG STRIX Z390-E GAMING, BIOS 1802 12/01/2020
[25125.960666] RIP: 0010:__slab_free+0x256/0x450
[25125.960681] Code: 4c 24 20 e8 bc 73 8e 00 8b 74 24 0c 44 0f b6 5c 24 13 44 8b 44 24 14 4c 8b 54 24 18 48 89 04 24 4c 8b 4c 24 20 e9 53 fe ff ff <0f> 0b 41 f7 46 08 00 0d 21 00 75 a2 eb 9b 0f 0b 80 4c 24 6b 80 45
[25125.960689] RSP: 0018:ffffaae587a0bd00 EFLAGS: 00010246
[25125.960697] RAX: ffff9fe38a876a70 RBX: 0000000080200006 RCX: ffff9fe38a876a00
[25125.960703] RDX: ffff9fe38a876a00 RSI: ffffdf45c42a1d80 RDI: ffff9fe38021e500
[25125.960708] RBP: ffffaae587a0bda8 R08: 0000000000000001 R09: ffffffffc0cc7a91
[25125.960713] R10: ffff9fe38a876a00 R11: 0000000000000000 R12: ffffdf45c42a1d80
[25125.960718] R13: ffff9fe38a876a00 R14: ffff9fe38021e500 R15: ffffdf45c42a1da0
[25125.960723] FS:  00007efc043dd800(0000) GS:ffff9feacdc00000(0000) knlGS:0000000000000000
[25125.960730] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[25125.960736] CR2: 00003ff70de7e000 CR3: 000000016ff6c003 CR4: 00000000003706e0
[25125.960742] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
[25125.960746] DR3: 0000000000000000 DR6: 00000000fffe0ff0 DR7: 0000000000000400
[25125.960751] Call Trace:
[25125.960756]  ? del_timer_sync+0x57/0x80
[25125.960770]  ? finish_wait+0x42/0x80
[25125.960779]  ? __hci_cmd_sync_ev+0x1f3/0x250 [bluetooth]
[25125.960889]  kmem_cache_free+0x3f7/0x430
[25125.960901]  ? btusb_shutdown_intel_new+0x31/0x50 [btusb]
[25125.960914]  btusb_shutdown_intel_new+0x31/0x50 [btusb]
[25125.960926]  hci_dev_do_close+0x41d/0x570 [bluetooth]
[25125.961006]  hci_rfkill_set_block+0x4c/0x90 [bluetooth]
[25125.961082]  rfkill_set_block+0x92/0x160 [rfkill]
[25125.961097]  rfkill_fop_write+0x114/0x1c0 [rfkill]
[25125.961109]  vfs_write+0xbf/0x270
[25125.961122]  ksys_write+0x87/0xc0
[25125.961134]  do_syscall_64+0x33/0x40
[25125.961145]  entry_SYSCALL_64_after_hwframe+0x44/0xa9
[25125.961153] RIP: 0033:0x7efc0473f7df
[25125.961161] Code: 89 54 24 18 48 89 74 24 10 89 7c 24 08 e8 79 47 f9 ff 48 8b 54 24 18 48 8b 74 24 10 41 89 c0 8b 7c 24 08 b8 01 00 00 00 0f 05 <48> 3d 00 f0 ff ff 77 31 44 89 c7 48 89 44 24 08 e8 cc 47 f9 ff 48
[25125.961168] RSP: 002b:00007ffe16a94810 EFLAGS: 00000293 ORIG_RAX: 0000000000000001
[25125.961176] RAX: ffffffffffffffda RBX: 00007efc043dd788 RCX: 00007efc0473f7df
[25125.961181] RDX: 0000000000000008 RSI: 000055ee4f123fb0 RDI: 0000000000000008
[25125.961185] RBP: 00007ffe16a94860 R08: 0000000000000000 R09: 000000000000000b
[25125.961190] R10: 0000000000000000 R11: 0000000000000293 R12: 0000000000000001
[25125.961194] R13: 00007ffe16a948c0 R14: 0000000000000000 R15: 000055ee4f11a820
[25125.961202] Modules linked in: uinput snd_seq_dummy snd_hrtimer rfcomm ccm dummy nf_tables ebtable_nat ebtable_broute ip6table_nat ip6table_mangle ip6table_raw ip6table_security iptable_nat nf_nat nf_conntrack nf_defrag_ipv6 nf_defrag_ipv4 iptable_mangle iptable_raw iptable_security ip_set nfnetlink ebtable_filter ebtables ip6table_filter ip6_tables iptable_filter cmac bnep sunrpc squashfs vfat fat loop snd_sof_pci snd_sof_intel_hda_common snd_sof_intel_hda snd_sof_intel_byt snd_sof_intel_ipc snd_sof intel_rapl_msr intel_rapl_common snd_sof_xtensa_dsp snd_soc_skl snd_hda_codec_realtek snd_hda_codec_generic snd_soc_hdac_hda ledtrig_audio snd_hda_ext_core snd_soc_sst_ipc snd_hda_codec_hdmi snd_soc_sst_dsp snd_soc_acpi_intel_match snd_soc_acpi snd_hda_intel snd_intel_dspcfg soundwire_intel soundwire_generic_allocation iwlmvm snd_soc_core x86_pkg_temp_thermal intel_powerclamp snd_compress iTCO_wdt intel_pmc_bxt mei_hdcp ee1004 iTCO_vendor_support snd_pcm_dmaengine mac80211 coretemp
[25125.961337]  soundwire_cadence snd_usb_audio rapl snd_hda_codec intel_cstate uvcvideo eeepc_wmi libarc4 intel_uncore snd_usbmidi_lib snd_hda_core videobuf2_vmalloc snd_rawmidi videobuf2_memops asus_wmi i2c_i801 ac97_bus videobuf2_v4l2 iwlwifi pcspkr snd_seq sparse_keymap mxm_wmi wmi_bmof videobuf2_common btusb mei_me i2c_smbus snd_hwdep cfg80211 mei snd_seq_device btrtl videodev btbcm snd_pcm btintel bluetooth snd_timer joydev mc snd ecdh_generic rfkill soundcore ecc acpi_pad acpi_tad zram ip_tables dm_crypt hid_logitech_hidpp hid_logitech_dj amdgpu drm_ttm_helper ttm iommu_v2 gpu_sched i2c_algo_bit drm_kms_helper cec crct10dif_pclmul crc32_pclmul crc32c_intel nvme drm e1000e ghash_clmulni_intel nvme_core wmi video pinctrl_cannonlake fuse
[25125.961509] ---[ end trace a0714a1f0d0a90d4 ]---

Comment 11 Benjamin Berg 2021-05-03 08:23:41 UTC
Robert, the old backtrace that includes gsd-rfkill is explained by an old bug in gnome-settings-daemon. That bug should be fixed.

As for the other situation. Please make sure that "rfkill" shows all bluetooth devices as unblocked.

If you see the USB device while gnome-control-center is not showing the scan list, then we are probably dealing with BT being switched off in bluetoothd. This would be purely a userspace issue, and you should be able to escape that state simply by running "bluetoothctl power on".

Robert, please check if "bluetoothctl power on" helps.

Comment 12 Benjamin Berg 2021-05-03 13:32:08 UTC
Reassigning to bluez.

I am pretty certain that this is bluetoothd not reading the rfkill events correctly (and then ending up thinking that bluetooth is simply disabled).

The USB related issue seems rare, and while likely an issue, mostly unrelated.

https://marc.info/?l=linux-bluetooth&m=162004753229953&w=2

Scratch build to test: https://koji.fedoraproject.org/koji/taskinfo?taskID=67144417

I'll open a PR for the bluez package as soon as my fork is writeable (it includes a patch to use g_memdup2 to avoid FTBFS due to deprecation, I have not checked all g_memdup uses and did not submit this patch upstream because of that).

Comment 15 Fedora Update System 2021-05-18 13:42:47 UTC
FEDORA-2021-2cd83da751 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-2cd83da751

Comment 16 Fedora Update System 2021-05-19 02:20:33 UTC
FEDORA-2021-2cd83da751 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-2cd83da751`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-2cd83da751

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 17 Fedora Update System 2021-05-20 01:12:12 UTC
FEDORA-2021-2cd83da751 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 18 spassky9999 2021-07-31 19:13:44 UTC
Found by accident, the Settings Power Bluetooth Switch off to save power button and the Settings Bluetooth On/off button have the same identity clearly an error. This was observed using xorg desktop. It makes using a bluetooth keyboard very difficult and almost impossible to relianly use for any length of time. Hope this helps and that the fix is so simple. Thanks for your attention. Kindest Regards.


Note You need to log in before you can comment on or make changes to this bug.