Bug 1944504 - [ceph-ansible] cephadm-adopt - nfs (ganesha) services are not adopted
Summary: [ceph-ansible] cephadm-adopt - nfs (ganesha) services are not adopted
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Ansible
Version: 5.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 5.0
Assignee: Guillaume Abrioux
QA Contact: Vasishta
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-03-30 05:01 UTC by Vasishta
Modified: 2021-08-30 08:29 UTC (History)
7 users (show)

Fixed In Version: ceph-ansible-6.0.3-1.el8cp
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-08-30 08:29:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github ceph ceph-ansible pull 6413 0 None closed [skip ci] cephadm_adopt: various fixes 2021-04-14 06:09:15 UTC
Red Hat Issue Tracker RHCEPH-1250 0 None None None 2021-08-30 00:19:52 UTC
Red Hat Product Errata RHBA-2021:3294 0 None None None 2021-08-30 08:29:39 UTC

Description Vasishta 2021-03-30 05:01:59 UTC
Description of problem:
nfs ganesha services are not adopted after successful completion of cephadm-adopt playbook

Version-Release number of selected component (if applicable):
ceph-ansible-6.0.2-1.el8cp.noarch.rpm

How reproducible:
Tried twice faced twice

Steps to Reproduce:
1. Configure 4.x bare metal cluster
2. run rpm-to-containerized playbook
3. upgrade ceph-ansible to 6.x, run rolling updated
4. run cephadm-adopt playbook

Actual results:
>> cluster health detail
[WRN] CEPHADM_STRAY_DAEMON: 1 stray daemon(s) not managed by cephadm
    stray daemon 34506 on host ceph-vasi-node6-osd-rgw-nfs not managed by cephadm

>> (container name still has old convention name)
82e6581713c8  registry-proxy.engineering.redhat.com/rh-osbs/rhceph:ceph-5.0-rhel-8-containers-candidate-22961-20210324054847                                      18 hours ago  Up 18 hours ago          ceph-nfs-ceph-vasi-node6-osd-rgw-nfs


Expected results:
All daemons must get adopted by cephadm

Additional info:

Comment 10 errata-xmlrpc 2021-08-30 08:29:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (Red Hat Ceph Storage 5.0 bug fix and enhancement), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:3294


Note You need to log in before you can comment on or make changes to this bug.