Bug 1944531 - python-qdarkstyle fails to build with Python 3.10: ImportError: cannot import name 'Sequence' from 'collections'
Summary: python-qdarkstyle fails to build with Python 3.10: ImportError: cannot import...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-qdarkstyle
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mukundan Ragavan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1969117 (view as bug list)
Depends On:
Blocks: F35FTBFS F35FailsToInstall PYTHON3.10
TreeView+ depends on / blocked
 
Reported: 2021-03-30 06:38 UTC by Tomáš Hrnčiar
Modified: 2021-06-15 20:42 UTC (History)
3 users (show)

Fixed In Version: python-qdarkstyle-3.0.2-1.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-06-15 20:42:01 UTC
Type: Bug


Attachments (Terms of Use)

Description Tomáš Hrnčiar 2021-03-30 06:38:02 UTC
python-qdarkstyle fails to build with Python 3.10.0a6.

scss (unittest.loader._FailedTest) ... ERROR

======================================================================
ERROR: scss (unittest.loader._FailedTest)
----------------------------------------------------------------------
ImportError: Failed to import test module: scss
Traceback (most recent call last):
  File "/usr/lib64/python3.10/unittest/loader.py", line 154, in loadTestsFromName
    module = __import__(module_name)
  File "/builddir/build/BUILD/QDarkStyle-2.8.1/qdarkstyle/utils/scss.py", line 14, in <module>
    import qtsass
  File "/usr/lib/python3.10/site-packages/qtsass/__init__.py", line 14, in <module>
    from qtsass.api import compile, compile_filename, compile_dirname, watch
  File "/usr/lib/python3.10/site-packages/qtsass/api.py", line 13, in <module>
    from collections import Sequence, Mapping
ImportError: cannot import name 'Sequence' from 'collections' (/usr/lib64/python3.10/collections/__init__.py)


----------------------------------------------------------------------
Ran 1 test in 0.000s

FAILED (errors=1)
Test failed: <unittest.runner.TextTestResult run=1 errors=1 failures=0>
error: Test failed: <unittest.runner.TextTestResult run=1 errors=1 failures=0>

bpo-37324: Remove deprecated aliases to Collections Abstract Base Classes
from the collections module.

https://docs.python.org/3.10/whatsnew/changelog.html#python-3-10-0-alpha-6

For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.10/fedora-rawhide-x86_64/02107534-python-qdarkstyle/

For all our attempts to build python-qdarkstyle with Python 3.10, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/package/python-qdarkstyle/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.10:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/

Let us know here if you have any questions.

Python 3.10 will be included in Fedora 35. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.10.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Mukundan Ragavan 2021-04-03 00:39:47 UTC
I think qdarkstyle needs to be updated anyway. Let me look into that.

Comment 2 Miro Hrončok 2021-06-04 20:12:49 UTC
This is a mass-posted update. Sorry if it is not 100% accurate to this bugzilla.


The Python 3.10 rebuild is in progress in a Koji side tag. If you manage to fix the problem, please commit the fix in the rawhide branch, but don't build the package in regular rawhide.

You can either build the package in the side tag, with:

    $ fedpkg build --target=f35-python

Or you can the build and we will eventually build it for you.

Note that the rebuild is still in progress, so not all (build) dependencies of this package might be available right away.

Thanks.

See also https://fedoraproject.org/wiki/Changes/Python3.10

If you have general questions about the rebuild, please use this mailing list thread: https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/G47SGOYIQLRDTWGOSLSWERZSSHXDEDH5/

Comment 3 Mukundan Ragavan 2021-06-05 22:01:25 UTC
I have updated git to 3.0.2. This *should* build once dependencies are done.

Comment 4 Miro Hrončok 2021-06-05 22:05:40 UTC
The dependencies are not yet ready in the side tag, but they are ready in the testing copr:

https://copr.fedorainfracloud.org/coprs/g/python/python3.10/package/python-qdarkstyle/

The 3.0.2 commit still failed with:

======================================================================
ERROR: utils (unittest.loader._FailedTest)
----------------------------------------------------------------------
ImportError: Failed to import test module: utils
Traceback (most recent call last):
  File "/usr/lib64/python3.10/unittest/loader.py", line 154, in loadTestsFromName
    module = __import__(module_name)
  File "/builddir/build/BUILD/QDarkStyle-3.0.2/qdarkstyle/utils/__init__.py", line 18, in <module>
    from qdarkstyle.utils.scss import create_qss
  File "/builddir/build/BUILD/QDarkStyle-3.0.2/qdarkstyle/utils/scss.py", line 14, in <module>
    import qtsass
  File "/usr/lib/python3.10/site-packages/qtsass/__init__.py", line 14, in <module>
    from qtsass.api import compile, compile_filename, compile_dirname, watch
  File "/usr/lib/python3.10/site-packages/qtsass/api.py", line 13, in <module>
    from collections import Sequence, Mapping
ImportError: cannot import name 'Sequence' from 'collections' (/usr/lib64/python3.10/collections/__init__.py)


======================================================================
ERROR: qdarkstyle.utils (unittest.loader._FailedTest)
----------------------------------------------------------------------
ImportError: Failed to import test module: qdarkstyle.utils
Traceback (most recent call last):
  File "/usr/lib64/python3.10/unittest/loader.py", line 470, in _find_test_path
    package = self._get_module_from_name(name)
  File "/usr/lib64/python3.10/unittest/loader.py", line 377, in _get_module_from_name
    __import__(name)
  File "/builddir/build/BUILD/QDarkStyle-3.0.2/qdarkstyle/utils/__init__.py", line 18, in <module>
    from qdarkstyle.utils.scss import create_qss
  File "/builddir/build/BUILD/QDarkStyle-3.0.2/qdarkstyle/utils/scss.py", line 14, in <module>
    import qtsass
  File "/usr/lib/python3.10/site-packages/qtsass/__init__.py", line 14, in <module>
    from qtsass.api import compile, compile_filename, compile_dirname, watch
  File "/usr/lib/python3.10/site-packages/qtsass/api.py", line 13, in <module>
    from collections import Sequence, Mapping
ImportError: cannot import name 'Sequence' from 'collections' (/usr/lib64/python3.10/collections/__init__.py)


----------------------------------------------------------------------
Ran 2 tests in 0.000s




I am afraid this is a problem in python-qtsass, which itself built fine, becasue there is no %check to fail there.

Comment 5 Mukundan Ragavan 2021-06-05 22:08:53 UTC
Ah, that's the COPR I was looking for. 

I knew about that failure and filed a report upstream. That is indeed qtsass and is fixed in git upstream https://github.com/spyder-ide/qtsass/pull/54/commits. However, there is no release yet.

I will have to update qtsass to 0.3.0 and pull this PR in.

Comment 6 Mukundan Ragavan 2021-06-05 22:40:01 UTC
This is fixed.

https://copr.fedorainfracloud.org/coprs/nonamedotc/spyder5/builds/


I will push qtsass momentarily.

Comment 7 Mukundan Ragavan 2021-06-05 22:53:19 UTC
qtsass built successfully on the side-tag.

https://koji.fedoraproject.org/koji/taskinfo?taskID=69393032

Comment 8 Miro Hrončok 2021-06-07 22:57:48 UTC
The f35-python side tag has been merged to Rawhide. From now on, build as you would normally build.

Comment 9 Miro Hrončok 2021-06-08 11:32:08 UTC
*** Bug 1969117 has been marked as a duplicate of this bug. ***

Comment 10 Miro Hrončok 2021-06-15 20:26:26 UTC
Hello,

This is the first reminder (step 3 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


Note You need to log in before you can comment on or make changes to this bug.