Bug 194473 - prelink cannot append to prelink.log file
prelink cannot append to prelink.log file
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: prelink (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
: 181783 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-08 08:59 EDT by Mike
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.3.8-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-21 06:59:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike 2006-06-08 08:59:19 EDT
Description of problem:

Jun  8 04:02:15 xxx kernel: audit(1149732135.028:4): avc:  denied  { append }
for  pid=2639 comm="prelink" name="prelink.log" dev=hda1 ino=458825
scontext=user_u:system_r:prelink_t:s0 tcontext=user_u:object_r:var_log_t:s0
tclass=file
Jun  8 04:02:15 xxx kernel: audit(1149732135.028:5): avc:  denied  { append }
for  pid=2639 comm="prelink" name="prelink.log" dev=hda1 ino=458825
scontext=user_u:system_r:prelink_t:s0 tcontext=user_u:object_r:var_log_t:s0
tclass=file

Version-Release number of selected component (if applicable):

clean/fresh/minimal/yesterday install with all updates

How reproducible:

leave system for night ;)

Actual results:

# getfattr -d -h -m. /var/log/prelink.log
getfattr: Removing leading '/' from absolute path names
# file: var/log/prelink.log
security.selinux="user_u:object_r:var_log_t:s0\000"

Expected results:

# getfattr -d -h -m. /var/log/prelink.log
getfattr: Removing leading '/' from absolute path names
# file: var/log/prelink.log
security.selinux="system_u:object_r:prelink_log_t:s0\000"

Additional info:

I don't know why this file have wrong context.
`restorecon /var/log/prelink.log` helps but real problem is cause of this.
Comment 1 Daniel Walsh 2006-06-15 21:50:37 EDT
We need to move prelink to its own directory /var/log/prelink/prelink.log
Comment 2 Jakub Jelinek 2006-06-21 06:59:52 EDT
Should be fixed by prelink-0.3.8-1 in dist-fc6.
Comment 3 Jakub Jelinek 2006-07-12 05:31:41 EDT
*** Bug 198523 has been marked as a duplicate of this bug. ***
Comment 4 Jakub Jelinek 2006-08-08 06:24:52 EDT
*** Bug 181783 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.