Bug 19449 - Netscape wrapper confuses WindowMaker
Netscape wrapper confuses WindowMaker
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: WindowMaker (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-20 03:39 EDT by dh_redhat
Modified: 2007-04-18 12:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-12 17:34:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dh_redhat 2000-10-20 03:39:11 EDT
If I invoke Netscape as /usr/bin/netscape (which is a sh wrapper 
around /usr/lib/netscape-communicator) then I cannot dock the application 
in WindowMaker, it cannot be saved in a WindowMaker session and  I cannot 
set other properties.

If I invoke it directly as /usr/lib/netscape-communicator then everything 
works as expected.

A 'ps' when invoked as /usr/bin/netscape shows two processes:

21654 21559 39 00:39 tty1     00:00:04 /usr/lib/netscape/netscape-commu
21667 21654  0 00:39 tty1     00:00:00 [netscape <defunct>]

I suspect it is related to the <defunct> process. Could it be because when 
the wrapper invokes the real executable it does not 'exec' it?
Comment 1 Bill Nottingham 2000-10-27 18:50:10 EDT
The defunct process is actually either
 A) a dns helper
 b) a previous dead netscape process

It doesn't really have anything to do with the wrapper.
Comment 2 dh_redhat 2000-10-28 16:37:24 EDT
How do you explain then the fact that the <defunct> process shows up *ONLY* 
when starting netscape through the wrapper? I just tried it again, I started 
Netscape directly and actively used it for a while to rule out the DNS process, 
after using it for about 15 min. there is still no <defunct> process. I quit, 
checked ps again, no sign of any running Netscape at all, then started Netscape 
using the wrapper, the <defunct> process showed up right away.
Comment 3 Bill Nottingham 2001-01-19 17:16:52 EST
Hm, this appears to be a bug in WindowMaker's docking; it's
expecting the PID that it launched to stay running, but since
the shell script actually executes netscape, it's not being watched
correctly.
Comment 4 Crutcher Dunnavant 2001-04-12 17:34:15 EDT
But the shell script 'exec's netscape. hmm.
Comment 5 Crutcher Dunnavant 2001-06-25 13:33:20 EDT
I dont think that this can be called a bug in WindowMaker.
What possible behaviour could it have than to wait on the process?
Should it wait on the process's children; which one?

Note You need to log in before you can comment on or make changes to this bug.