Bug 194518 - primary.xml.gz for 'extras' downloaded again and again
Summary: primary.xml.gz for 'extras' downloaded again and again
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: yumex   
(Show other bugs)
Version: 5
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Tim Lauridsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-06-08 17:43 UTC by Sudarsan Sridhar
Modified: 2014-01-21 22:54 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-06 07:46:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sudarsan Sridhar 2006-06-08 17:43:52 UTC
DComponent: yumex
Version: 1.0.1
Summary: TB3fa42680 threading.py:532:join:AssertionError: cannot join current thread

Traceback (most recent call last):
  File "/usr/lib/python2.4/atexit.py", line 24, in _run_exitfuncs
    func(*targs, **kargs)
  File "/usr/lib/python2.4/threading.py", line 634, in __exitfunc
    t.join()
  File "/usr/lib/python2.4/threading.py", line 532, in join
    assert self is not currentThread(), "cannot join current thread"
AssertionError: cannot join current thread

Local variables in innermost frame:
self: <BackgroundRunner(Thread-3, started)>
timeout: None

Comment 1 Tim Lauridsen 2006-06-19 13:17:04 UTC
Yumex uses a backgroud thread to download repository metadata, the error occours
somewwhere inside the Python threading code, i have no clue what is going wrong.
Do this happends every time or did it happen just once.

Comment 2 Sudarsan Sridhar 2006-06-22 13:58:54 UTC
This happens everytime

Comment 3 Tim Lauridsen 2006-08-24 10:39:38 UTC
This error occours when quiting yumex, while running in a thread.

The multiple downloading of primary.xml.gz can be caused by some defective yum
metadata.
Try running 'yum clean all' (as root)
before running yumex.



Note You need to log in before you can comment on or make changes to this bug.