Bug 1945530 - LUKS: 5.11.11 won't unlock luks lvm; 5.11.10 does
Summary: LUKS: 5.11.11 won't unlock luks lvm; 5.11.10 does
Keywords:
Status: CLOSED DUPLICATE of bug 1945596
Alias: None
Product: Fedora
Classification: Fedora
Component: dracut
Version: 34
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: dracut-maint-list
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1945440 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-04-01 08:20 UTC by Dr. David Alan Gilbert
Modified: 2021-04-06 11:34 UTC (History)
26 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-04-06 08:23:09 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Dr. David Alan Gilbert 2021-04-01 08:20:14 UTC
1. Please describe the problem:
Today I switched my laptop on, entered the passphrase into the graphical crypt prompt and.... it sat there with the spinning icon.
I managed to get to the text console and it showed the systemd saying it was waiting for the root and swap.

2. What is the Version-Release number of the kernel:
5.11.11-300.fc34

3. Did it work previously in Fedora? If so, what kernel version did the issue
   *first* appear?  Old kernels are available for download at
   https://koji.fedoraproject.org/koji/packageinfo?packageID=8 :

5.11.11-300 it fails (twice out of 2 goes), I switched back to 5.11.10 and it's fine.

4. Can you reproduce this issue? If so, please provide the steps to reproduce
   the issue below:
Switch laptop on
Enter luks passphrase

5. Does this problem occur with the latest Rawhide kernel? To install the
   Rawhide kernel, run ``sudo dnf install fedora-repos-rawhide`` followed by
   ``sudo dnf update --enablerepo=rawhide kernel``:
Not sure yet.

6. Are you running any modules that not shipped with directly Fedora's kernel?:
No

7. Please attach the kernel logs. You can get the complete kernel log
   for a boot with ``journalctl --no-hostname -k > dmesg.txt``. If the
   issue occurred on a previous boot, use the journalctl ``-b`` flag.

It didn't get to unlock root so it didn't store the logs.

Comment 1 Justin M. Forbes 2021-04-01 23:51:40 UTC
This is not kernel related, this is a dracut bug (don't rebuild your 5.11.10 initramfs).  I believe the fix is https://github.com/dracutdevs/dracut/commit/7fcc4955884355c3943d6c41e459b4b983a818f4

Comment 2 Justin M. Forbes 2021-04-01 23:52:27 UTC
*** Bug 1945440 has been marked as a duplicate of this bug. ***

Comment 3 David Sanz 2021-04-02 14:07:20 UTC
Same error here after upgrading from F33, using LVM for all partitions.

Using old boot line on grub from F33 works fine

Comment 4 Chris Murphy 2021-04-04 02:17:27 UTC
See also bug 1945596 and bug 1945901 and 1945950.

Comment 5 Chris Murphy 2021-04-04 04:28:47 UTC
OK never mind, as figured out in bug 1945596, this is the fix.

https://github.com/dracutdevs/dracut/commit/ba4bcf5f4f11ad624c647ddf4f566997186135e7

Comment 6 David Sanz 2021-04-04 10:19:01 UTC
(In reply to Chris Murphy from comment #5)
> OK never mind, as figured out in bug 1945596, this is the fix.
> 
> https://github.com/dracutdevs/dracut/commit/
> ba4bcf5f4f11ad624c647ddf4f566997186135e7

Fixed after applying that.

Complete instructions:

- Boot with any old kernel (for example, the one from F33 before upgrade)
- Edit file /usr/lib/dracut/modules.d/35network-manager/nm-run.service with the new line specified on the commit
- Regenerate initramfs:  dracut -v --force --kver 5.11.10-300.fc34.x86_64 (check the correct kernel version on your system, it could be newer)
- reboot

Comment 7 Dr. David Alan Gilbert 2021-04-06 08:23:09 UTC
OK, given comments above; thanks all and duping to 1945596

*** This bug has been marked as a duplicate of bug 1945596 ***


Note You need to log in before you can comment on or make changes to this bug.