Bug 194584 - snmpd doesn't proper support IPv6 MIB
snmpd doesn't proper support IPv6 MIB
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: net-snmp (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jan Safranek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-14 04:18 EDT by Radek Vokal
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-15 04:29:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Radek Vokal 2006-06-14 04:18:33 EDT
Description of problem:
snmpwalk doesn't show any IPv6 related entry.

Version-Release number of selected component (if applicable):
net-snmp-5.1.2-11.EL4.6

How reproducible:
every time

Steps to Reproduce:
1. install net-snmp
2. configure /etc/snmp/snmpd.conf to be able to retrieve the whole tree
3. $ snmpwalk -c public -v 2c host | grep -i ipv6
  
Actual results:
IPV6-MIB::ipv6Forwarding.0 = INTEGER: forwarding(1)
IPV6-MIB::ipv6DefaultHopLimit.0 = INTEGER: 64
IPV6-MIB::ipv6Interfaces.0 = Gauge32: 5
IPV6-MIB::ipv6IfDescr.1 = STRING: lo
IPV6-MIB::ipv6IfDescr.2 = STRING: eth0
IPV6-MIB::ipv6IfDescr.3 = STRING: eth1
IPV6-MIB::ipv6IfDescr.4 = STRING: eth2
IPV6-MIB::ipv6IfDescr.8 = STRING: tun6to4
IPV6-MIB::ipv6IfLowerLayer.1 = OID: SNMPv2-SMI::zeroDotZero
IPV6-MIB::ipv6IfLowerLayer.2 = OID: SNMPv2-SMI::zeroDotZero
IPV6-MIB::ipv6IfLowerLayer.3 = OID: SNMPv2-SMI::zeroDotZero
IPV6-MIB::ipv6IfLowerLayer.4 = OID: SNMPv2-SMI::zeroDotZero
IPV6-MIB::ipv6IfLowerLayer.8 = OID: SNMPv2-SMI::zeroDotZero
IPV6-MIB::ipv6IfEffectiveMtu.1 = Gauge32: 16436 octets
IPV6-MIB::ipv6IfEffectiveMtu.2 = Gauge32: 1500 octets
IPV6-MIB::ipv6IfEffectiveMtu.3 = Gauge32: 1500 octets
IPV6-MIB::ipv6IfEffectiveMtu.4 = Gauge32: 1500 octets
IPV6-MIB::ipv6IfEffectiveMtu.8 = Gauge32: 1480 octets
IPV6-MIB::ipv6IfPhysicalAddress.1 = STRING:
IPV6-MIB::ipv6IfPhysicalAddress.2 = STRING: 0:1:2:**:**:**
IPV6-MIB::ipv6IfPhysicalAddress.3 = STRING: 0:0:cb:**:**:**
IPV6-MIB::ipv6IfPhysicalAddress.4 = STRING: 0:0:e8:**:**:**
IPV6-MIB::ipv6IfPhysicalAddress.8 = STRING: 54:99:56:**:**:**
IPV6-MIB::ipv6IfAdminStatus.1 = INTEGER: up(1)
IPV6-MIB::ipv6IfAdminStatus.2 = INTEGER: up(1)
IPV6-MIB::ipv6IfAdminStatus.3 = INTEGER: down(2)
IPV6-MIB::ipv6IfAdminStatus.4 = INTEGER: up(1)
IPV6-MIB::ipv6IfAdminStatus.8 = INTEGER: up(1)
IPV6-MIB::ipv6IfOperStatus.1 = INTEGER: up(1)
IPV6-MIB::ipv6IfOperStatus.2 = INTEGER: up(1)
IPV6-MIB::ipv6IfOperStatus.3 = INTEGER: up(1)
IPV6-MIB::ipv6IfOperStatus.4 = INTEGER: up(1)
IPV6-MIB::ipv6IfOperStatus.8 = INTEGER: up(1)

Expected results:
ipv6IfTable entries containing the IPv6 addresses of the interface

Also missing: IPv6-TCP and IPv6-UDP

Additional info:
net-snmp-5.3-4.2 of FC5 does the job (for the interfaces, not for TCP/UDP, will
file an additional bug), but uses also the new MIB layout where IPv4 and IPv6 is
combined in IP-MIB
Comment 1 Jan Safranek 2007-06-15 04:29:55 EDT
ipv6AddrTable OID is not implemented in net-snmp-5.1.2. It is not possible to
port it back from net-snmp-5.2.1, because it uses lot of features of the newer
version.

It could be possible to reimplement the OID from scratch, but it would take
quite lot of effort. If you want this OID implemented, please contact your Red
Hat support :).

You can use RHEL 5, where the ipv6AddrTable is properly implemented.

Note You need to log in before you can comment on or make changes to this bug.