Bug 1945851 - Unnecessary series churn when a new version of kube-state-metrics is rolled out
Summary: Unnecessary series churn when a new version of kube-state-metrics is rolled out
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Monitoring
Version: 4.7
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.7.z
Assignee: Jan Fajerski
QA Contact: Junqi Zhao
URL:
Whiteboard:
: 1931896 (view as bug list)
Depends On: 1945849
Blocks: 1931896 1946597
TreeView+ depends on / blocked
 
Reported: 2021-04-02 09:13 UTC by Simon Pasquier
Modified: 2021-05-25 15:08 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of: 1945849
: 1946597 (view as bug list)
Environment:
Last Closed: 2021-04-20 18:52:39 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-monitoring-operator pull 1101 0 None closed Bug 1945851: Backport Remove the "instance" and "pod" labels for kube-state-metrics metrics 2021-04-15 08:36:00 UTC
Red Hat Product Errata RHBA-2021:1149 0 None None None 2021-04-20 18:52:59 UTC

Comment 2 Junqi Zhao 2021-04-12 01:03:42 UTC
tested with 4.7.0-0.nightly-2021-04-10-082109
pod label exists for kube_pod_info is expected, no instance label for it
kube_pod_info{namespace="openshift-monitoring"}
kube_pod_info{container="kube-rbac-proxy-main", created_by_kind="DaemonSet", created_by_name="node-exporter", endpoint="https-main", host_ip="10.0.130.185", job="kube-state-metrics", namespace="openshift-monitoring", node="ip-10-0-130-185.us-east-2.compute.internal", pod="node-exporter-x2bw5", pod_ip="10.0.130.185", priority_class="system-cluster-critical", service="kube-state-metrics", uid="c407cd8e-de07-4c10-b203-935874306853"}

the instance and pod labels are absent for other kube_* metrics, example
kube_node_role
kube_node_role{container="kube-rbac-proxy-main", endpoint="https-main", job="kube-state-metrics", namespace="openshift-monitoring", node="ip-10-0-130-185.us-east-2.compute.internal", role="master", service="kube-state-metrics"}

Comment 5 errata-xmlrpc 2021-04-20 18:52:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.7.7 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:1149

Comment 6 Jan Fajerski 2021-05-25 15:08:47 UTC
*** Bug 1931896 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.