Bug 194601 - can't use gphoto2 as user
can't use gphoto2 as user
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gphoto2 (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Bacovsky
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-14 07:15 EDT by Bob T.
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-10 08:05:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of gphoto2 --debug --get-all-files (14.77 KB, text/plain)
2006-06-14 07:15 EDT, Bob T.
no flags Details

  None (edit)
Description Bob T. 2006-06-14 07:15:02 EDT
Description of problem: Access to pictures works as root, but not as user.




Version-Release number of selected component (if applicable):2.1.99-8 and
2.1.99-14 (rawhide)


How reproducible: always


Steps to Reproduce:
1. gphoto2 --get-all-files
2.
3.
  
Actual results:

An error occurred in the io-library ('Could not claim the USB device'): Could
not claim interface 0 (Operation not permitted). Make sure no other program or
kernel module (such as sdc2xx, stv680, spca50x) is using the device and you have
read/write access to the device.
*** Error (-53: 'Could not claim the USB device') ***  




Expected results: downloading all the pictures; this is what happens when I do
this as root.


Additional info: This may be a duplicate of bug 189936. This was originally
submitted on 2006-06-12 (bug 194926) but lost in a hardware crash.

Camera detection works:

% gphoto2 --auto-detect
Model                          Port                                            
----------------------------------------------------------
Canon Digital IXUS 55 (PTP mode) usb:
Comment 1 Bob T. 2006-06-14 07:15:04 EDT
Created attachment 130822 [details]
output of gphoto2 --debug --get-all-files
Comment 2 Martin Bacovsky 2006-08-10 08:05:25 EDT
It seems that uour problem and its solution is described in gphoto FAQ.
See http://www.gphoto.org/doc/manual/FAQ.html#FAQ-could-not-claim-USB.

If it is not that case, please, reopen this bug and we will try to fix that.
Comment 3 Bob T. 2006-08-10 09:15:27 EDT
The FAQ links to

http://www.gphoto.org/doc/manual/permissions-usb.html

which talks mainly about using hotplug. As far as I can tell, there is no RPM
for Fedora that provides hotplug. The file
 
/proc/sys/kernel/hotplug

exists but is empty. Should I use the insecure method:

  allow a certain user and/or group or the whole world access to all USB devices

or is there a more secure alternative in Fedora?

Note You need to log in before you can comment on or make changes to this bug.