Bug 194614 - Not able to print some pages of a PDF file
Not able to print some pages of a PDF file
Status: CLOSED DUPLICATE of bug 217660
Product: Fedora
Classification: Fedora
Component: ghostscript (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-14 08:37 EDT by Dawid Gajownik
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-15 08:39:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Mentioned PDF file (786.10 KB, application/pdf)
2006-06-14 08:37 EDT, Dawid Gajownik
no flags Details
CUPS error log (45.20 KB, text/plain)
2006-06-14 08:45 EDT, Dawid Gajownik
no flags Details

  None (edit)
Description Dawid Gajownik 2006-06-14 08:37:17 EDT
(Due to bugzilla crash I resubmit this bug report - previous ID: #194898)

Description of problem:
I'm not able to print 3rd and 4th page of attached PDF file.

Version-Release number of selected component (if applicable):
cups-1.2.1-1.7
hpijs-0.9.11-1.2
foomatic-3.0.2-33.3
ghostscript-8.15.2-1.1

Steps to Reproduce:
1. Open attached PDF file in kpdf or evince
2. Try to print 3rd page
  
Actual results:
Error in /var/log/cups/error_log.

Expected results:
Printed page.

Additional info:
I asked my friend to print it and he had the same result on updated FC5 and
Canon printer.
Comment 1 Dawid Gajownik 2006-06-14 08:37:17 EDT
Created attachment 130834 [details]
Mentioned PDF file
Comment 2 Dawid Gajownik 2006-06-14 08:45:16 EDT
Created attachment 130837 [details]
CUPS error log

This is the most important part:

E [12/Jun/2006:19:15:57 +0200] [Job 56] /undefined in --get--
D [12/Jun/2006:19:15:57 +0200] [Job 56] Operand stack:
D [12/Jun/2006:19:15:57 +0200] [Job 56] (sta\263ego x)	 36.5157  
--dict:14/17(ro)(L)--	32   space   --dict:14/14(ro)(L)--   space
D [12/Jun/2006:19:15:57 +0200] [Job 56] Execution stack:
D [12/Jun/2006:19:15:57 +0200] [Job 56] %interp_exit   .runexec2  
--nostringval--   --nostringval--   --nostringval--   2   %stopped_push  
--nostringval--   --nostringval--   --nostringval--   false   1   %stopped_push
  1   3   %oparray_pop	 1   3	 %oparray_pop	1   3	%oparray_pop   1   3  
%oparray_pop   .runexec2   --nostringval--   --nostringval--   --nostringval-- 
 2   %stopped_push   --nostringval--   --nostringval--	 %finish_stringwidth  
--nostringval--   --nostringval--   8	9   2	--nostringval--  
(gs_show_enum)	 %op_show_continue   --nostringval--   --nostringval--
D [12/Jun/2006:19:15:57 +0200] [Job 56] Dictionary stack:
D [12/Jun/2006:19:15:57 +0200] [Job 56] --dict:1138/1686(ro)(G)--  
--dict:1/20(G)--   --dict:87/200(L)--	--dict:67/75(L)--   --dict:18/24(L)--  
--dict:0/15(L)--   --dict:0/15(L)--   --dict:2/15(L)--	 --dict:4/15(L)--  
--dict:14/17(ro)(L)--
D [12/Jun/2006:19:15:57 +0200] [Job 56] Current allocation mode is local
D [12/Jun/2006:19:15:57 +0200] [Job 56] Last OS error: 2
D [12/Jun/2006:19:15:57 +0200] [Job 56] ESP Ghostscript 815.02: Unrecoverable
error, exit code 1
D [12/Jun/2006:19:15:58 +0200] [Job 56] renderer return value: 1
D [12/Jun/2006:19:15:58 +0200] [Job 56] renderer received signal: 1
D [12/Jun/2006:19:15:58 +0200] [Job 56] Process dying with "Possible error on
renderer command line or PostScript error. Check options.", exit stat: 3
D [12/Jun/2006:19:15:58 +0200] [Job 56] error: Błędne przesunięcie (29)
D [12/Jun/2006:19:15:58 +0200] [Job 56] Possible error on renderer command line
or PostScript error. Check options.
D [12/Jun/2006:19:15:58 +0200] [Job 56] tail process done writing data to
STDOUT
D [12/Jun/2006:19:15:58 +0200] [Job 56] KID4 finished
D [12/Jun/2006:19:15:58 +0200] [Job 56] KID3 exited with status 3
D [12/Jun/2006:19:15:58 +0200] [Job 56] Renderer exit stat: 3
D [12/Jun/2006:19:15:58 +0200] [Job 56] Renderer process finished
D [12/Jun/2006:19:15:58 +0200] [Job 56] Killing process 5275 (KID3)
D [12/Jun/2006:19:15:58 +0200] [Job 56] Process dying with "Error closing
renderer", exit stat: 3
D [12/Jun/2006:19:15:58 +0200] [Job 56] error: Błędne przesunięcie (29)
D [12/Jun/2006:19:15:58 +0200] [Job 56] Error closing renderer
E [12/Jun/2006:19:15:58 +0200] PID 5270 (/usr/lib/cups/filter/foomatic-rip)
stopped with status 3!

"Błędne przesunięcie" means in "Wrong offset" or something similar.

BTW why Polish messages are encoded in ISO-8859-2? My system works in UTF-8
(pl_PL.UTF-8).
Comment 3 Tim Waugh 2006-12-15 08:39:23 EST
Seems to have the same cause as bug #217660.

*** This bug has been marked as a duplicate of 217660 ***

Note You need to log in before you can comment on or make changes to this bug.