Bug 1946193 - Snapshot creation after blocking connection from host to storage fails
Summary: Snapshot creation after blocking connection from host to storage fails
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: vdsm
Classification: oVirt
Component: Core
Version: 4.40.50.8
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: ovirt-4.4.7
: 4.40.70.6
Assignee: Liran Rotenberg
QA Contact: Evelina Shames
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-04-05 10:08 UTC by Evelina Shames
Modified: 2021-07-06 09:52 UTC (History)
4 users (show)

Fixed In Version: vdsm-4.40.70.3
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-07-06 09:52:35 UTC
oVirt Team: Virt
pm-rhel: ovirt-4.4+


Attachments (Terms of Use)
Logs (2.46 MB, application/zip)
2021-04-05 10:08 UTC, Evelina Shames
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 114118 0 master MERGED snapshot: fix teardown handling 2021-06-08 13:17:07 UTC

Description Evelina Shames 2021-04-05 10:08:59 UTC
Created attachment 1769232 [details]
Logs

Description of problem:
When a VM runs on a non SPM host, and snapshot operation is running but the connection from host to storage is blocked, operation fails as expected. But, when unblocking the connection and trying to create another snapshot - operation fails when it should succeed.
I've seen this issue in our automation tests a few times, it was hard to reproduce and lately it reproduces all the time (automation) and after deep investigation and help from Liran, decided to open a bug.

Version-Release number of selected component (if applicable):
Versions from the last automation failure (I managed to reproduce also on rhv-4.4.5.7):
vdsm-4.40.50.8-1.el8ev.x86_64
ovirt-engine-4.4.5.10-0.1.el8ev.noarch
libvirt-6.6.0-13.module+el8.3.1+9548+0a8fede5.x86_64

How reproducible:
100% by automation, I'll try to reproduce manually and share the results.

Steps to Reproduce:
- Create VM from template
- Start VM on non SPM host
- Block connection from host to storage
- Try to create snapshot - Operation should fail
- Unblock connection from host to storage
- Create a new snapshot

Actual results:
The second snapshot fails.

Expected results:
The first snapshot should fail and the second should be created successfully.

Additional info:
Attaching logs from automation run (engnie+art+vdsm)
and another reproduction with libvirt logs as well.

Comment 1 Evelina Shames 2021-07-06 09:07:24 UTC
Verified on rhv-4.4.7-6 by running the automation TC that failed - TestCase26126 Passed.

Moving to 'Verified'.

Comment 2 Arik 2021-07-06 09:52:35 UTC
This bugzilla is included in oVirt 4.4.7 release, published on July 6th 2021.

Since the problem described in this bug report should be resolved in oVirt 4.4.7 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.