Bug 1946347 - The Boot ISO installer for CentOS Stream 8 doesn't offer any mirrors that are needed to do the installation
Summary: The Boot ISO installer for CentOS Stream 8 doesn't offer any mirrors that are...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: anaconda
Version: CentOS Stream
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: beta
: 8.5
Assignee: Jiri Konecny
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-04-05 20:28 UTC by Steven Rosenberg
Modified: 2021-11-10 00:45 UTC (History)
9 users (show)

Fixed In Version: anaconda-33.16.5.1-1.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1955331 (view as bug list)
Environment:
Last Closed: 2021-11-09 18:42:11 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)
Installation Source scfreen (864.42 KB, image/jpeg)
2021-04-05 20:28 UTC, Steven Rosenberg
no flags Details
Anaconda before the network is set up (1.40 MB, image/jpeg)
2021-04-05 20:29 UTC, Steven Rosenberg
no flags Details
Anaconda after the network is set up (639.17 KB, image/jpeg)
2021-04-05 20:29 UTC, Steven Rosenberg
no flags Details
Installation Source error message (859.02 KB, image/jpeg)
2021-04-05 20:30 UTC, Steven Rosenberg
no flags Details
Installation Source error popup (1.83 MB, image/jpeg)
2021-04-05 20:30 UTC, Steven Rosenberg
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2021:4254 0 None None None 2021-11-09 18:42:23 UTC

Description Steven Rosenberg 2021-04-05 20:28:41 UTC
Created attachment 1769362 [details]
Installation Source scfreen

Description of problem:

When running the Boot ISO of the CentOS Stream 8 installer, no mirrors are offered to the user, who must somehow figure out that manually entering http://mirror.centos.org/centos/8-stream/BaseOS/x86_64/os/ is one way to continue and successfully install the system

Version-Release number of selected component (if applicable):

CentOS-Stream-8-x86_64-20210331-boot.iso
and
CentOS-Stream-8-x86_64-20210316-boot.iso


How reproducible:








Steps to Reproduce:
1. Start the CentOS Stream 8 installer
2. Set up networking
3. Go to the Installation Source spoke of Anaconda, where no mirrors are offered

Actual results:

Installation cannot proceed until the user finds the URL to a working mirror from a search on another device.

Expected results:

Anaconda offers a number of mirrors that the user can select to complete the installation.

Additional info:

Comment 1 Steven Rosenberg 2021-04-05 20:29:28 UTC
Created attachment 1769363 [details]
Anaconda before the network is set up

Comment 2 Steven Rosenberg 2021-04-05 20:29:53 UTC
Created attachment 1769364 [details]
Anaconda after the network is set up

Comment 3 Steven Rosenberg 2021-04-05 20:30:22 UTC
Created attachment 1769365 [details]
Installation Source error message

Comment 4 Steven Rosenberg 2021-04-05 20:30:57 UTC
Created attachment 1769366 [details]
Installation Source error popup

Comment 5 Jiri Konecny 2021-04-15 13:33:56 UTC
Just for verification, could you please try to run the installation with `ip=dhcp` kernel boot parameter? If I'm correct than you should be able to start the installation as expected.

Comment 6 Steven Rosenberg 2021-04-19 17:28:16 UTC
I ran with ip=dhcp as a kernel boot parameter, and there was no change. Still no mirrors offered.

Comment 7 Brian Stinson 2021-04-23 03:56:47 UTC
With CentOS-Stream-8-x86_64-20210421-boot.iso (anaconda 33.16.4.15-1.el8) I see that we're missing repo files in /etc/anaconda.repos.d/

Looking into this.

Comment 8 Jiri Konecny 2021-04-26 11:47:56 UTC
Hi. Yes, Brian is correct. Installation environment is missing repo files.

The problem seems to be in the `centos-stream-release` package. It should provide `centos-stream-repos` package but this dependency seems to be missing.

Switching component to what seems to be the correct one.

Comment 9 Lisa S 2021-04-26 15:11:44 UTC
RHELBLD doesn't manage the centos-stream-release package, only the redhat-release package.  So redhat-release component is the incorrect component as well.  

Brian, what component should this be in for your team?

Comment 10 Carl George 🤠 2021-04-26 16:34:37 UTC
I don't believe we have a component in bugzilla for centos-stream-release.  It should be fine to use the distribution component for this in the future.

centos-stream-release had a recommends for centos-stream-repos, but it seems that lorax is hard coded for install_weak_deps=false [0], so I've switched that to a requires [1].  I generated a new compose with that change and gave it to Jiri for additional troubleshooting.

[0] https://github.com/weldr/lorax/blob/lorax-28.14.58-1/src/pylorax/dnfbase.py#L81
[1] https://git.centos.org/rpms/centos-stream-release/c/9eda8dbd66a0fe26479e403f69001b54885c7c5c?branch=c8s

Comment 11 Jiri Konecny 2021-04-26 16:39:55 UTC
Thanks for switching it back. After fixing the the centos-stream-release issue we found out that CentOS Stream also renamed repositories. Problem with that is that Anaconda is matching base repository which is requirement to set the sources successfully. However, now we are not able to match BaseOS repository because it's named baseos on CentOS Stream.

CentOS Stream done this renaming to make the names consistent and they would rather avoid changing it back. So we will fix this in Anaconda to solve this issue.

Because the original issue is not tracked on bugzilla. I will re-use this bug because it's still the same user impact.

Comment 12 Jiri Konecny 2021-04-26 16:48:04 UTC
PR: https://github.com/rhinstaller/anaconda/pull/3313

Comment 17 Carl George 🤠 2021-05-02 15:29:49 UTC
We've applied the upstream fixes as patches to the CentOS anaconda package.  The CentOS-Stream-8-x86_64-20210427-boot.iso image includes the new package, and has a functional "closest mirror" option after the network is enabled.

Comment 18 Steven Rosenberg 2021-05-03 03:54:36 UTC
I can confirm that this now works. "Closest Mirror" is a working option in the Stream 8 installer.

Comment 20 Petr Zatko 2021-06-03 13:45:31 UTC
Tested with anaconda-core-33.16.5.2-1, verified that the patch is present.

Comment 24 Jan Stodola 2021-08-05 09:17:43 UTC
anaconda-33.16.5.3-1.el8 is present in RHEL-8.5.0-20210730.n.0.
Moving to VERIFIED based on comments 18,20.

Comment 26 errata-xmlrpc 2021-11-09 18:42:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (anaconda bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:4254


Note You need to log in before you can comment on or make changes to this bug.