RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Bug 1946500 - RFE: backport commit e921913eecd5025dae688fdf9c365023fe3b8a0c (SELinux support)
Summary: RFE: backport commit e921913eecd5025dae688fdf9c365023fe3b8a0c (SELinux support)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: strace
Version: 8.3
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Eugene Syromiatnikov
QA Contact: Jesus Checa
URL:
Whiteboard:
Depends On:
Blocks: 2000565 2000566 2000913
TreeView+ depends on / blocked
 
Reported: 2021-04-06 09:20 UTC by Renaud Métrich
Modified: 2021-11-10 10:29 UTC (History)
11 users (show)

Fixed In Version: strace-5.7-3.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 2000565 2000566 2000913 (view as bug list)
Environment:
Last Closed: 2021-11-09 20:06:48 UTC
Type: Bug
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2021:4514 0 None None None 2021-11-09 20:06:56 UTC

Description Renaud Métrich 2021-04-06 09:20:25 UTC
Description of problem:

I'm requesting a backport of commit e921913eecd5025dae688fdf9c365023fe3b8a0c to our standard strace tool shipped with RHEL8.
This brings up the SELinux context functionality which is tremendously welcome when CEE has to deal with SELinux issues. It enables to spot more easily what's wrong by analyzing the contexts the processes are transitioning to or file contexts.

Version-Release number of selected component (if applicable):

strace-5.1-1.el8.x86_64


How reproducible:

N/A

Comment 2 Eugene Syromiatnikov 2021-08-24 20:32:19 UTC
Testing notes: for m32, libselinux.i686 and libselinux-devel.i686 are to be installed.  Presence of the selinux context decoding feature is indicated by the presence of "secontext" on the "Optional features enabled" line in `strace -V` output.

Comment 24 errata-xmlrpc 2021-11-09 20:06:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (strace bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2021:4514


Note You need to log in before you can comment on or make changes to this bug.