Bug 1946773 - GUI terminal emits "undecodable token:" warnings
Summary: GUI terminal emits "undecodable token:" warnings
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: octave
Version: 34
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Orion Poplawski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-04-06 19:23 UTC by Otto Liljalaakso
Modified: 2021-04-24 20:08 UTC (History)
7 users (show)

Fixed In Version: octave-5.2.0-12.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-04-24 20:08:42 UTC
Type: Bug


Attachments (Terms of Use)

Description Otto Liljalaakso 2021-04-06 19:23:18 UTC
Description of problem:
On Fedora, Octave gui emits the following kind of warning on startup and after each Enter:

  undecodable token: \001b(hex)[?2004l
  undecodable token: \001b(hex)[?2004h

Version-Release number of selected component (if applicable):
5.2.0-11.fc34

How reproducible:
Always

Steps to Reproduce:
1. Start Octave Gui
2. Type in something and press Enter

Actual results:
"Undecodable token" warnings seen at startup and after each Enter

Expected results:
No warnings seen, only normal output.

Additional info:
It is this bug from upstream, triggered by readline package being updated to 8.1 in Fedora 34, which enables "bracketed paste mode" by default: https://savannah.gnu.org/bugs/?func=detailitem&item_id=59483

The bug is closed upstream and comment contain a list of commits that fix this. With some luck they are easy to apply to Fedora's version of Octave.

Comment 1 Orion Poplawski 2021-04-07 02:53:21 UTC
Well, it was perhaps a little more complicated than I hoped - can you test out this build? - https://koji.fedoraproject.org/koji/taskinfo?taskID=65358877

Comment 2 Otto Liljalaakso 2021-04-07 08:12:30 UTC
Tested. The reported error is gone, I think this update is ready Bodhi. Thank you for acting so quickly.

There is another problem, text is not pasted to Octave Gui. But that was the case even in the current version in F34 repositories, so it is not a regression from your update. I cannot find a related bug in upstream tracker. I will investigate and file any bugs as needed. I do not think the paste bug needs to block resolving this bug, because it seems unrelated.

Comment 3 Otto Liljalaakso 2021-04-07 19:06:52 UTC
(In reply to Otto Urpelainen from comment #2)
> There is another problem, text is not pasted to Octave Gui. But that was the
> case even in the current version in F34 repositories, so it is not a
> regression from your update. I cannot find a related bug in upstream
> tracker. I will investigate and file any bugs as needed. I do not think the
> paste bug needs to block resolving this bug, because it seems unrelated.

I managed to reproduce this issue in multiple different setups. Not related to this bug here, reported upsteam as a separate issue: https://savannah.gnu.org/bugs/?60356

Comment 4 Fedora Update System 2021-04-09 18:26:10 UTC
FEDORA-2021-de13772322 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-de13772322

Comment 5 Fedora Update System 2021-04-10 21:37:07 UTC
FEDORA-2021-de13772322 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-de13772322`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-de13772322

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 6 Fedora Update System 2021-04-24 20:08:42 UTC
FEDORA-2021-de13772322 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.