Bug 1947157 - disk image creation fails when excluding kernel-lpae on 32-bit arm
Summary: disk image creation fails when excluding kernel-lpae on 32-bit arm
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 34
Hardware: arm
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Vendula Poncova
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: ARMTracker F34FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2021-04-07 19:37 UTC by Paul Whalen
Modified: 2021-04-14 19:36 UTC (History)
8 users (show)

Fixed In Version: anaconda-34.24.9-1 anaconda-34.24.9-1.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-04-14 19:36:43 UTC
Type: Bug


Attachments (Terms of Use)

Description Paul Whalen 2021-04-07 19:37:15 UTC
Description of problem:

The 32-bit arm disk images include both kernel and kernel-lpae. Kernel-lpae is usually installed last and the dtb symlink created points to the lpae dtb folder which does not contain all dtb files. This causes a boot failure on some devices. 

We have attempted to exclude kernel-lpae from the installation by adding "-kernel-lpae*" to the package section but this caused all the images to fail waiting for input:

Question                                                                                                                                                                                   

         Problems in request:
         missing packages: kernel-lpae                                       
         Would you like to ignore this and continue with installation?
 
Please respond 'yes' or 'no':

Version-Release number of selected component (if applicable):
anaconda-34.24.8-1.fc34.armv7hl

Expected results:

kernel-lpae should not be required for the installation.

Disk image failure in F34:
https://koji.fedoraproject.org/koji/taskinfo?taskID=65387595

Comment 1 Paul Whalen 2021-04-07 19:57:58 UTC
Proposing as a blocker for F34, this prevents us from creating a release blocking image (Minimal armhfp).

Comment 2 Adam Williamson 2021-04-07 21:05:26 UTC
Note the code in anaconda that requires kernel-lpae to be in the package set if available was added in 2013 in response to this bug:
https://bugzilla.redhat.com/show_bug.cgi?id=1013015
commit is https://github.com/rhinstaller/anaconda/commit/ffe01087ce10c80c991776c92f30c669c5a50e01 (the logic has been moved/tweaked since but the basic idea is the same).

Comment 3 Vendula Poncova 2021-04-08 10:06:22 UTC
Hi, I am not sure how to fix the issue in the context of the bug 1013015.

1. Is the current behaviour a regression?
2. Should we drop the support for the kernel-lpae package?
3. Should we extend the condition for the installation of the kernel-lpae package?
4. Should we allow to exclude the package kernel-lpae from the installation in a kickstart file?

Comment 4 Paul Whalen 2021-04-08 15:29:34 UTC
I think perhaps #3, extending the logic to prefer lpae if available but not require it. This would allow us to exclude it in the kickstart(#4) to make disk images that will boot on all hardware.

Comment 5 Vendula Poncova 2021-04-08 17:03:38 UTC
Fixed in a pull request: https://github.com/rhinstaller/anaconda/pull/3284

Comment 6 Adam Williamson 2021-04-08 22:03:58 UTC
+3 in https://pagure.io/fedora-qa/blocker-review/issue/336 , marking accepted.

Comment 7 Fedora Update System 2021-04-12 13:11:09 UTC
FEDORA-2021-394fedac1d has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-394fedac1d

Comment 8 Vendula Poncova 2021-04-12 13:27:03 UTC
Just a note, it is necessary to use -kernel-lpae in the %packages section. The -kernel-lpae* option will not work.

Comment 9 Fedora Update System 2021-04-12 15:10:26 UTC
FEDORA-2021-394fedac1d has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-394fedac1d`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-394fedac1d

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 10 Paul Whalen 2021-04-12 20:25:09 UTC
(In reply to Vendula Poncova from comment #8)
> Just a note, it is necessary to use -kernel-lpae in the %packages section.
> The -kernel-lpae* option will not work.

Thanks Vendula. 

PR for the kickstart change - https://pagure.io/fedora-kickstarts/pull-request/802

Comment 11 Fedora Update System 2021-04-14 19:36:43 UTC
FEDORA-2021-394fedac1d has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.