Bug 1947312 - bochs-display: there's no video object in REST API and REST default video type for UEFI server is incorrect.
Summary: bochs-display: there's no video object in REST API and REST default video typ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: RestAPI
Version: 4.4.5.11
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: ovirt-4.4.7
: ---
Assignee: Shmuel Melamud
QA Contact: Nisim Simsolo
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-04-08 08:04 UTC by Nisim Simsolo
Modified: 2021-07-06 07:28 UTC (History)
4 users (show)

Fixed In Version: ovirt-engine-4.4.7.4
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-07-06 07:28:00 UTC
oVirt Team: Virt
pm-rhel: ovirt-4.4+


Attachments (Terms of Use)
engine.log (40.95 KB, application/x-xz)
2021-04-08 08:10 UTC, Nisim Simsolo
no flags Details
VM dumpxml (13.05 KB, text/plain)
2021-04-08 08:10 UTC, Nisim Simsolo
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 115269 0 master MERGED restapi: Setting bochs display with REST API 2021-06-16 12:56:25 UTC

Description Nisim Simsolo 2021-04-08 08:04:49 UTC
Description of problem:
1. Using REST API, there's no object of type 'video' for setting video type to bochs.
2. When creating new VM, using REST API with Q35 chipset UEFI and 'server' type, the VM video type/graphics protocol is set to QXL/VNC instead of bochs/VNC.


Version-Release number of selected component (if applicable):
ovirt-engine-4.4.5.11-0.1.el8ev
vdsm-4.40.50.10-1.el8ev.x86_64
libvirt-daemon-6.6.0-13.module+el8.3.1+9548+0a8fede5.x86_64
qemu-kvm-5.1.0-20.module+el8.3.1+9918+230f5c26.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Using REST API, create new VM with Q35 UEFI chipset and 'server' configuration.
2.
3.

Actual results:
VM created with video type/graphics protocol QXL/VNC instead of bochs/VNC.

Expected results:
video type/graphics shout be set to bochs/VNC by default.

Additional info:
engine.log (VM created at 2021-04-08 10:57:22,076+03) and VM domxml attached.

Comment 1 Nisim Simsolo 2021-04-08 08:10:17 UTC
Created attachment 1770170 [details]
engine.log

Comment 2 Nisim Simsolo 2021-04-08 08:10:50 UTC
Created attachment 1770172 [details]
VM dumpxml

Comment 3 Arik 2021-04-12 11:29:22 UTC
To scope this one - just to align the default that is set by the API with the one from the UI (setting bochs-display for UEFI guests by default)

Comment 4 Nisim Simsolo 2021-06-27 15:11:22 UTC
Verified: 
ovirt-engine-4.4.7.4-0.9.el8ev
vdsm-4.40.70.4-1.el8ev.x86_64
qemu-kvm-5.2.0-16.module+el8.4.0+11536+725e25d9.2.x86_64
libvirt-daemon-7.0.0-14.1.module+el8.4.0+11095+d46acebf.x86_64

Comment 5 Sandro Bonazzola 2021-07-06 07:28:00 UTC
This bugzilla is included in oVirt 4.4.7 release, published on July 6th 2021.

Since the problem described in this bug report should be resolved in oVirt 4.4.7 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.