Bug 1947916 - Copied CSVs show up as adopted components
Summary: Copied CSVs show up as adopted components
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.6
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.6.z
Assignee: Evan Cordell
QA Contact: xzha
URL:
Whiteboard:
: 1866577 (view as bug list)
Depends On: 1947909
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-04-09 14:07 UTC by OpenShift BugZilla Robot
Modified: 2021-05-20 17:43 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-05-12 12:18:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github operator-framework operator-lifecycle-manager pull 2094 0 None open [release-4.6] Bug 1947916: Don't adopt copied csvs 2021-04-16 13:01:08 UTC
Red Hat Product Errata RHBA-2021:1487 0 None None None 2021-05-12 12:18:29 UTC

Comment 2 xzha 2021-04-29 06:36:17 UTC
verify:

zhaoxia@xzha-mac openshift-tests-private % oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.6.0-0.nightly-2021-04-28-215709   True        False         13m     Cluster version is 4.6.0-0.nightly-2021-04-28-215709
zhaoxia@xzha-mac openshift-tests-private % oc exec catalog-operator-5fbfffc95d-rtwgd -- olm --version
OLM version: 0.16.1
git commit: 349e71f821d7fd176ede64ff021506c144c62455

1) Install an AllNAmespace operator
zhaoxia@xzha-mac bug-1946838 % cat sub.yaml 
apiVersion: operators.coreos.com/v1alpha1
kind: Subscription
metadata:
  name: klusterlet-operator
  namespace: openshift-operators
spec:
  channel: stable
  installPlanApproval: Automatic
  name: klusterlet
  source: community-operators
  sourceNamespace: openshift-marketplace
zhaoxia@xzha-mac bug-1946838 % oc apply -f sub.yaml 
subscription.operators.coreos.com/klusterlet-operator created

zhaoxia@xzha-mac bug-1946838 % oc get csv -A
NAMESPACE                                          NAME                DISPLAY          VERSION   REPLACES            PHASE
default                                            klusterlet.v0.3.0   Klusterlet       0.3.0     klusterlet.v0.2.0   Succeeded
kube-node-lease                                    klusterlet.v0.3.0   Klusterlet       0.3.0     klusterlet.v0.2.0   Succeeded
kube-public                                        klusterlet.v0.3.0   Klusterlet       0.3.0     klusterlet.v0.2.0   Succeeded
kube-system                                        klusterlet.v0.3.0   Klusterlet       0.3.0     klusterlet.v0.2.0   Succeeded
openshift-apiserver-operator                       klusterlet.v0.3.0   Klusterlet       0.3.0     klusterlet.v0.2.0   Succeeded
....

2) add a new namespace
zhaoxia@xzha-mac bug-1946838 % oc new-project test-1
Now using project "test-1" on server "https://api.xzha0429-4.6.qe.azure.devcluster.openshift.com:6443".

You can add applications to this project with the 'new-app' command. For example, try:

    oc new-app rails-postgresql-example

to build a new example application in Ruby. Or use kubectl to deploy a simple Kubernetes application:

    kubectl create deployment hello-node --image=k8s.gcr.io/serve_hostname

zhaoxia@xzha-mac bug-1946838 % oc get csv -n test-1
NAME                DISPLAY      VERSION   REPLACES            PHASE
klusterlet.v0.3.0   Klusterlet   0.3.0     klusterlet.v0.2.0   
zhaoxia@xzha-mac bug-1946838 % oc get operator -n test-1
NAME                                                AGE
cluster-logging.openshift-logging                   17m
elasticsearch-operator.openshift-operators-redhat   17m
klusterlet.openshift-operators                      2m9s

3) View the Operator object 
zhaoxia@xzha-mac bug-1946838 % oc get operator klusterlet.openshift-operators -o yaml | grep -i Copied 
zhaoxia@xzha-mac bug-1946838 % oc get operator klusterlet.openshift-operators -o yaml | grep -i reason 
        reason: MinimumReplicasAvailable
        reason: NewReplicaSetAvailable
        reason: NoConflicts
        reason: InitialNamesAccepted
        reason: AllCatalogSourcesHealthy
        reason: InstallSucceeded

LGTM, verified.

Comment 5 errata-xmlrpc 2021-05-12 12:18:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6.28 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:1487

Comment 6 Ben Luddy 2021-05-20 17:43:24 UTC
*** Bug 1866577 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.