Bug 1948170 - Unable to watch on Netflix
Summary: Unable to watch on Netflix
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 34
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1895721 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-04-10 12:54 UTC by Basil Eric Rabi
Modified: 2022-07-16 21:41 UTC (History)
14 users (show)

Fixed In Version: firefox-87.0-12.fc33 firefox-87.0-12.fc32 firefox-87.0-12.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-04-14 14:43:32 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
strace while opening netflix (6.49 MB, text/plain)
2021-04-11 16:39 UTC, grumpey0
no flags Details
Upgraded packages on 4/8/2021 (9.84 KB, text/plain)
2021-04-11 16:44 UTC, grumpey0
no flags Details
Upgraded packages on 4/9/2021 (3.61 KB, text/plain)
2021-04-11 16:44 UTC, grumpey0
no flags Details
Upgraded packages on 4/10/2021 (3.33 KB, text/plain)
2021-04-11 16:52 UTC, grumpey0
no flags Details

Description Basil Eric Rabi 2021-04-10 12:54:25 UTC
Description of problem:
Today I was not able to watch anymore. It just says "Firefox is installing components needed to play audio or video on this page. Please try again later." although nothing is being downloaded when I check nethogs. I was still able to watch Netflix yesterday. I tried removing ~/.mozilla, ~/.cache/mozilla but still I can't watch on Netflix.

Version-Release number of selected component (if applicable):
firefox-87.0-7.fc34.x86_64

How reproducible:
100% today

Additional info:
Worked fine yesterday. Netflix still works with chromium-freeworld though.

Comment 1 rui.nibau 2021-04-11 12:07:47 UTC
Hello.

Can confirm the bug, not only for Netflix but every streaming service that need drm content decryption (Netflix, Amazon Prime, etc)

OS : Fedora 34 beta updated 2021-04-10
Firefox package: 87.0-7.fc34
Package repository: @fedora

Comment 2 grumpey0 2021-04-11 16:39:08 UTC
Created attachment 1771195 [details]
strace while opening netflix

Comment 3 grumpey0 2021-04-11 16:44:21 UTC
Created attachment 1771197 [details]
Upgraded packages on 4/8/2021

Comment 4 grumpey0 2021-04-11 16:44:56 UTC
Created attachment 1771198 [details]
Upgraded packages on 4/9/2021

Comment 5 grumpey0 2021-04-11 16:52:45 UTC
Created attachment 1771200 [details]
Upgraded packages on 4/10/2021

Comment 6 grumpey0 2021-04-11 16:54:36 UTC
According to my dnf logs, this version of firefox was installed from updates/testing on 4/2/2021 and this problem didn't start until 4/9 or 4/10? (Sorry not sure when)

Comment 7 Martin Stransky 2021-04-12 08:49:36 UTC
Please try firefox-87.0-12.fc34 builds at https://koji.fedoraproject.org/koji/packageinfo?packageID=37

Comment 8 Nils Tonnätt 2021-04-12 20:45:55 UTC
Netflix works again with this update.

Comment 9 Basil Eric Rabi 2021-04-12 22:35:26 UTC
Works for me too. Thank you!

Comment 10 Fedora Update System 2021-04-13 08:53:29 UTC
FEDORA-2021-b4c70f1156 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2021-b4c70f1156

Comment 11 Fedora Update System 2021-04-13 08:53:31 UTC
FEDORA-2021-8a58c211ac has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2021-8a58c211ac

Comment 12 Fedora Update System 2021-04-13 08:53:31 UTC
FEDORA-2021-b20dce00b2 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-b20dce00b2

Comment 13 Fedora Update System 2021-04-13 14:18:58 UTC
FEDORA-2021-b4c70f1156 has been pushed to the Fedora 32 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-b4c70f1156`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-b4c70f1156

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 14 Fedora Update System 2021-04-13 15:00:20 UTC
FEDORA-2021-8a58c211ac has been pushed to the Fedora 33 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-8a58c211ac`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-8a58c211ac

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 15 Fedora Update System 2021-04-14 14:43:32 UTC
FEDORA-2021-8a58c211ac has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 16 Fedora Update System 2021-04-14 16:31:53 UTC
FEDORA-2021-b20dce00b2 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-b20dce00b2

Comment 17 Fedora Update System 2021-04-14 17:13:56 UTC
FEDORA-2021-b20dce00b2 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-b20dce00b2`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-b20dce00b2

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 18 Fedora Update System 2021-04-17 14:20:48 UTC
FEDORA-2021-b4c70f1156 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 19 Martin Stransky 2021-04-18 09:57:48 UTC
*** Bug 1895721 has been marked as a duplicate of this bug. ***

Comment 20 Fedora Update System 2021-04-20 22:43:01 UTC
FEDORA-2021-b20dce00b2 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 21 James Wilson 2022-07-16 21:41:03 UTC Comment hidden (spam)

Note You need to log in before you can comment on or make changes to this bug.