Bug 1948350 - User profile screen at COPR shows link the the older FAS page even after Noggin was introduced
Summary: User profile screen at COPR shows link the the older FAS page even after Nogg...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Copr
Classification: Community
Component: frontend
Version: unspecified
Hardware: All
OS: All
unspecified
medium
Target Milestone: ---
Assignee: Copr Team
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-04-12 01:54 UTC by Akashdeep Dhar
Modified: 2021-04-28 12:04 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-04-28 12:04:47 UTC


Attachments (Terms of Use)
Clicking on t0xic0der (fas) takes me to https://admin.fedoraproject.org/ (FAS2) which is now deprecated (99.32 KB, image/png)
2021-04-12 01:56 UTC, Akashdeep Dhar
no flags Details

Description Akashdeep Dhar 2021-04-12 01:54:03 UTC
Description of problem:
On the profile screen, when someone clicks on their `<username> (fas)` link, they get redirected to the older FAS2 admin page which is now deprecated. The links should be reworked to redirect users to the new Fedora Accounts page.

Version-Release number of selected component (if applicable):
Not applicable.

How reproducible:
You must have a FAS account and should be able to log in to COPR.

Steps to Reproduce:
1. Log into COPR
2. Go to the profile page (Namely, https://copr.fedorainfracloud.org/coprs/<username>/)
3. See the link with the name `<username> (fas)`? Click on it.

Actual results:
Redirects to the older FAS2 admin page.

Expected results:
Should have redirected to the newer Fedora Accounts page.

Additional info:
Not applicable.

Comment 1 Akashdeep Dhar 2021-04-12 01:56:39 UTC
Created attachment 1771264 [details]
Clicking on t0xic0der (fas) takes me to https://admin.fedoraproject.org/ (FAS2) which is now deprecated

Comment 2 Jakub Kadlčík 2021-04-12 02:47:43 UTC
Thank you for the feedback Akashdeep,
Modified in https://pagure.io/copr/copr/pull-request/1767

Comment 3 Akashdeep Dhar 2021-04-12 03:37:08 UTC
(In reply to Jakub Kadlčík from comment #2)
> Thank you for the feedback Akashdeep,
> Modified in https://pagure.io/copr/copr/pull-request/1767

Thank you for addressing this ticket in your PR. :)

Comment 4 Pavel Raiskup 2021-04-12 05:56:14 UTC
I think bug 1943925 is related to this one.

Comment 5 Pavel Raiskup 2021-04-12 06:27:33 UTC
*** Bug 1943925 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.