Bug 1948435 - ldns fails to build with Python 3.10: configure: error: cannot import Python module "distutils".
Summary: ldns fails to build with Python 3.10: configure: error: cannot import Python ...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: ldns
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Menšík
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1968824 (view as bug list)
Depends On:
Blocks: F35FTBFS F35FailsToInstall PYTHON3.10
TreeView+ depends on / blocked
 
Reported: 2021-04-12 07:35 UTC by Tomáš Hrnčiar
Modified: 2021-06-18 11:46 UTC (History)
4 users (show)

Fixed In Version: ldns-1.7.1-7.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-06-18 11:46:56 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github NLnetLabs ldns pull 133 0 None open Update all m4 files from autoconf-archive project 2021-06-03 11:17:35 UTC
Github autoconf-archive autoconf-archive pull 232 0 None open Python devel update to sysconfig 2021-06-03 10:17:44 UTC

Description Tomáš Hrnčiar 2021-04-12 07:35:36 UTC
ldns fails to build with Python 3.10.0a7.

configure: error: cannot import Python module "distutils".
Please check your Python installation. The error was:
<string>:1: DeprecationWarning: The distutils package is deprecated and slated for removal in Python 3.12. Use setuptools or check PEP 632 for potential alternatives

bpo-41282: Deprecate distutils in documentation and add warning on import.
https://bugs.python.org/issue41282
https://www.python.org/dev/peps/pep-0632/

For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.10/fedora-rawhide-x86_64/02124561-ldns/

For all our attempts to build ldns with Python 3.10, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/package/ldns/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.10:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/

Let us know here if you have any questions.

Python 3.10 will be included in Fedora 35. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.10.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Miro Hrončok 2021-04-12 15:57:17 UTC
ldns-1.7.1_python3/ax_python_devel.m4 is outdated, it needs to contain this fix from 2017: http://git.savannah.gnu.org/gitweb/?p=autoconf-archive.git;a=commit;h=883a2abd5a and configure needs to be regenerated

Comment 2 Fedora Admin user for bugzilla script actions 2021-04-26 12:27:36 UTC
This package has changed maintainer in Fedora. Reassigning to the new maintainer of this component.

Comment 3 Petr Menšík 2021-06-03 11:24:22 UTC
Passed my build with proposed changes [1]. Not merging them until some reaction is received from upstream.

1. https://copr.fedorainfracloud.org/coprs/pemensik/ldns/build/2223072/

Comment 4 Miro Hrončok 2021-06-04 20:15:41 UTC
This is a mass-posted update. Sorry if it is not 100% accurate to this bugzilla.


The Python 3.10 rebuild is in progress in a Koji side tag. If you manage to fix the problem, please commit the fix in the rawhide branch, but don't build the package in regular rawhide.

You can either build the package in the side tag, with:

    $ fedpkg build --target=f35-python

Or you can the build and we will eventually build it for you.

Note that the rebuild is still in progress, so not all (build) dependencies of this package might be available right away.

Thanks.

See also https://fedoraproject.org/wiki/Changes/Python3.10

If you have general questions about the rebuild, please use this mailing list thread: https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/G47SGOYIQLRDTWGOSLSWERZSSHXDEDH5/

Comment 5 Miro Hrončok 2021-06-07 23:00:03 UTC
The f35-python side tag has been merged to Rawhide. From now on, build as you would normally build.

Comment 6 Miro Hrončok 2021-06-08 11:15:56 UTC
*** Bug 1968824 has been marked as a duplicate of this bug. ***

Comment 7 Petr Menšík 2021-06-18 11:46:56 UTC
No upstream reaction yet, built now with downstream patch.


Note You need to log in before you can comment on or make changes to this bug.