Bug 1948499 - liquidctl fails to build with Python 3.10: liquidctl/util.py:23: DocTestFailure
Summary: liquidctl fails to build with Python 3.10: liquidctl/util.py:23: DocTestFailure
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: liquidctl
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Artur Frenszek-Iwicki
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1968833 1972940 (view as bug list)
Depends On:
Blocks: PYTHON3.10 F35FTBFS F35FailsToInstall
TreeView+ depends on / blocked
 
Reported: 2021-04-12 10:00 UTC by Tomáš Hrnčiar
Modified: 2021-06-22 21:22 UTC (History)
3 users (show)

Fixed In Version: liquidctl-1.6.1-3.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-06-16 19:48:58 UTC
Type: Bug


Attachments (Terms of Use)

Description Tomáš Hrnčiar 2021-04-12 10:00:56 UTC
liquidctl fails to build with Python 3.10.0a7.

=================================== FAILURES ===================================
____________________ [doctest] liquidctl.util.Hue2Accessory ____________________
021 Mapping of HUE 2 accessory IDs and names.
022 
023     >>> Hue2Accessory(4)
Expected:
    <Hue2Accessory.HUE2_LED_STRIP_300: 4>
Got:
    Hue2Accessory.HUE2_LED_STRIP_300

/builddir/build/BUILD/liquidctl-1.6.0/liquidctl/util.py:23: DocTestFailure

For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.10/fedora-rawhide-x86_64/02124651-liquidctl/

For all our attempts to build liquidctl with Python 3.10, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/package/liquidctl/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.10:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/

Let us know here if you have any questions.

Python 3.10 will be included in Fedora 35. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.10.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Miro Hrončok 2021-06-04 20:14:13 UTC
This is a mass-posted update. Sorry if it is not 100% accurate to this bugzilla.


The Python 3.10 rebuild is in progress in a Koji side tag. If you manage to fix the problem, please commit the fix in the rawhide branch, but don't build the package in regular rawhide.

You can either build the package in the side tag, with:

    $ fedpkg build --target=f35-python

Or you can the build and we will eventually build it for you.

Note that the rebuild is still in progress, so not all (build) dependencies of this package might be available right away.

Thanks.

See also https://fedoraproject.org/wiki/Changes/Python3.10

If you have general questions about the rebuild, please use this mailing list thread: https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/G47SGOYIQLRDTWGOSLSWERZSSHXDEDH5/

Comment 2 Miro Hrončok 2021-06-07 22:58:53 UTC
The f35-python side tag has been merged to Rawhide. From now on, build as you would normally build.

Comment 3 Miro Hrončok 2021-06-08 11:16:53 UTC
*** Bug 1968833 has been marked as a duplicate of this bug. ***

Comment 4 Miro Hrončok 2021-06-15 20:26:37 UTC
Hello,

This is the first reminder (step 3 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 5 Fedora Update System 2021-06-16 19:46:00 UTC
FEDORA-2021-bd8412907f has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-bd8412907f

Comment 6 Fedora Update System 2021-06-16 19:48:58 UTC
FEDORA-2021-bd8412907f has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 7 Miro Hrončok 2021-06-16 23:53:52 UTC
*** Bug 1972940 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.