Bug 19488 - backspace key, incorrect control sequence
backspace key, incorrect control sequence
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2000-10-20 16:29 EDT by Matthew Roth
Modified: 2007-04-18 12:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-01-24 15:12:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Matthew Roth 2000-10-20 16:29:43 EDT
It appears that there was some sort of change between RH 6.1 and 6.2 with 
the backspace key mapping and the xterm command.  When I am on the console 
and I run an xterm my backspace key generates a "^?" but when I display 
the xterm onto my Windows NT system running Exceed, it generates a "^[[3~" 
sequence.  This didn't behave this way in RH 6.1.  Any ideas? Is there a 
way to control what sequence is sent?

Thanks for any help.
Comment 1 Matthew Roth 2000-12-07 09:42:57 EST
Sorry but I am new to this process, is the fact that the bug was assigned mean 
someone has reproduced the problem and its just waiting to worked on?

Also I just tried the 7.0 upgrade and it doesn't seem to resolve the problem.

Any help would be appreciated.  Thanks
Comment 2 Mike A. Harris 2001-09-23 13:17:04 EDT
Just tested this in the current release of Red Hat Linux 7.1
and backspace works in xterm.  Closing bug as fixed in CURRENTRELEASE.
Comment 3 Matthew Roth 2003-01-24 12:53:47 EST
This problem has reappeared in RH 7.3, I opened a support call with Redhat but 
they said I need to file a Bugzilla report.

I don't have a RH 8.0 system to test with yet to see if the problem went away.

Here is the information from the service request, 221828, I had opened.

Some time ago I had a problem with the backspace key not working the same 
between RH 6.1 and RH 6.2, attached it the final email from RedHat support 
saying it was fixed in RH 7.1 which is was and it works in 7.2, but when I 
upgrade to 7.3 the old behaviour reappeared.  Basically I have a Linux box and 
Windows box and I am using Exceed on Windows and I start an xterm on the Linux 
box and display it on my Windows desktop.  The Backspace key in 7.2 send 
the "^?" sequence and in 7.3 it sends the "^[[3~" sequence.  Is there a way for 

me to adjust the sequence that is being sent.  It sounded like it was 
considered bug before and fixed is it really bug or is it just that the default 

behaviour needs to be modified.  Below are three systems, one 6.2, one 7.2, and 

one 7.3, and the OS level and XFree86 level,  any help would be appreciated.

Thanks in advance.

RedHat 6.2 

   $ uname -r

   rpm -q -f /usr/bin/X11/xterm

   Backspace Key in an xterm ^[[3~

RedHat 7.2

   $ uname -r

   rpm -q -f /usr/bin/X11/xterm

   Backspace Key in an xterm ^?

RedHat 7.3

   $ uname -r

   $ rpm -q -f /usr/bin/X11/xterm

   Backspace Key in an xterm ^[[3~

Thanks in advance!
Comment 4 Mike A. Harris 2003-01-24 15:12:57 EST
This bug is a RHL 6.2 bug, is ancient, and is closed.  There are endless
debates about backspace / delete behaviour in Linux/UNIX systems, and
they all end up with one resolution:

What one person reports as a bug in one app, if modified to "fix" the
theoretical bs/del bug for them, breaks 10 apps for 1000 other users.

Endless bug reports come in, as the problem gets fixed for one user, then
changed to fix it for the other user and break it for the original. It is
a ping pong back and forth bs/del issue that was solved 3 or more years
ago.  The current default configuration of backspace and delete behaviour
are considered the official standard way they are to work in Linux.

Users requiring alternative configurations are free to tweak their
Xresource files, or per application config files in order to change the
system's default behaviour to something that works in a way they prefer.

Also, "xterm" is included for end user convenience due to it's legacy,
however it is officially not supported.  Users are encouraged to use
one of our supported terminal applications such as gnome-terminal or

Comment 5 Matthew Roth 2003-01-24 17:05:44 EST
I have tried to tweak its behavior using the HOWTO on backspaces but I have not 
had any luck. The issue doesn't seem to have been solved 3 years ago because it 
does not work the same from 7.2 to 7.3.

I would more more than happy with a way to tweak it that works, I will try to 
go back through the HOWTO to see if I missed anything.

xterm may be old but it is the only one consistantly on every box, Linux is a 
small part of the thousands of boxes we have.

Note You need to log in before you can comment on or make changes to this bug.