Bug 1948958 - Ingress details page doesn't show referenced secret name and link
Summary: Ingress details page doesn't show referenced secret name and link
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.8
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.7.z
Assignee: Joe Caiani
QA Contact: Yanping Zhang
URL:
Whiteboard: Scrubbed
Depends On: 1946922
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-04-13 07:10 UTC by OpenShift BugZilla Robot
Modified: 2021-07-27 11:23 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-05-19 15:15:46 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 8633 0 None open [release-4.7] Bug 1948958: Fix ingress details page to show referenced secret name 2021-04-19 20:49:29 UTC
Red Hat Product Errata RHBA-2021:1550 0 None None None 2021-05-19 15:16:14 UTC

Description OpenShift BugZilla Robot 2021-04-13 07:10:07 UTC
+++ This bug was initially created as a clone of Bug #1946922 +++

Description of problem:
On Ingress details page, `TLS certificate` shows 'Not configured' even a secret is referred 

Version-Release number of selected component (if applicable):
4.8.0-0.nightly-2021-04-05-174735

How reproducible:
Always

Steps to Reproduce:
1. create an ingress by specifying a Secret that contains a TLS private key and certificate
$ cat > tls-example-ingress.yaml << EOF
apiVersion: networking.k8s.io/v1
kind: Ingress
metadata:
  name: tls-example-ingress
spec:
  tls:
  - hosts:
      - https-example.foo.com
    secretName: testsecret-tls
  rules:
  - host: https-example.foo.com
    http:
      paths:
      - path: /
        pathType: Prefix
        backend:
          service:
            name: service1
            port:
              number: 80
EOF
$ oc create -f tls-example-ingress.yaml
$ oc get ingress tls-example-ingress -o json | jq .spec.tls
[
  {
    "hosts": [
      "https-example.foo.com"
    ],
    "secretName": "testsecret-tls"
  }
]

2. check Ingress details from Networking -> Ingresses -> tls-example-ingress


Actual results:
2. on Ingress details page, `TLS certificate` field shows a value 'Not configured' 

Expected results:
2. we should render a resource icon and link to the referred secret `testsecret-tls` 

Additional info:

Comment 4 Yanping Zhang 2021-05-12 06:31:15 UTC
The fix pr test has passed before merge, and the pr has been included in 4.7.0-0.nightly-2021-05-12-004740. So move the bug to Verified.

Comment 6 errata-xmlrpc 2021-05-19 15:15:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.7.11 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:1550


Note You need to log in before you can comment on or make changes to this bug.