Fedora Account System
Red Hat Associate
Red Hat Customer
Description of problem: Debug view showing 404 errors when a cleaned up debug resource request fails. Version-Release number of selected component (if applicable): How reproducible: Always Steps to Reproduce: 1. Start a migration 2. Observe migration in debug view 3. 404 occurs when a debug request for a cleaned up resource fails. Actual results: Shows 404 error for all debug request failures even if they are legitimate failures. Expected results: Hide 404s for failed request on auto-cleaned resources Additional info:
https://github.com/konveyor/mig-ui/commit/14a07f7d4fd554bcc6837b9999a3bab618da46f1
Verified using MTC 1.5.0 openshift-migration-rhel7-operator@sha256:00e77706ca22bcb557d13c16822180fc877e6ea1639a72fda8eb9f5488b039a2 - name: MIG_CONTROLLER_REPO value: openshift-migration-controller-rhel8@sha256 - name: MIG_CONTROLLER_TAG value: 7f657df15e9514df4ef42da3431f558a19b8d3233a2ef1222cd8e27793c93816 - name: MIG_UI_REPO value: openshift-migration-ui-rhel8@sha256 - name: MIG_UI_TAG value: bda1959e1f44170905499b304ce28f9f95ee1841b0dc29f9a9e2790d0dd0bd71 No 404 error displayed in the debug view any more. Moved to VERIFIED.
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. For information on the advisory (Migration Toolkit for Containers (MTC) image release advisory 1.5.0), and where to find the updated files, follow the link below. If the solution does not work for you, open a new bug report. https://access.redhat.com/errata/RHEA-2021:2929