This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 195001 - system-config-bind is not fully localized although translation is 100% (all_lang)
system-config-bind is not fully localized although translation is 100% (all_l...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-bind (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
: Reopened, StringChange
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-14 09:09 EDT by Ankit Patel
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-14 09:07:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ankit Patel 2006-06-14 09:09:11 EDT
Description of problem:
Import, Preview, Manual..., TO DO (Translator Credit) messages are in English

Version-Release number of selected component (if applicable):
4.0.0-41_FC6

How reproducible:
Everytime

Steps to Reproduce:
1. Run "system-config-bind" in any native language
2. Check for the mentioned messages in Menu, toobar, etc.
3.
  
Actual results:
Messages are displayed in English

Expected results:
Messages should be displayed in Native language

Additional info:
Comment 1 Jason Vas Dias 2006-06-14 23:01:47 EDT
This is very strange. 
Nearly every .po file contains the translations for the .glade file Tool Bar
strings, such as fr.po:
"
#: ../system-config-bind.glade:231 ../system-config-bind.glade.h:18
msgid "Import"
msgstr "Importer"
"
These strings are properly marked as 'translatable' in the .glade file, and
intltool-extract correctly writes them to the .pot file, but libglade / libgtk2
/ pygtk2 (one of these components - not sure yet which) is not looking up the
translation and on the .glade file load with 'gtk.glade.XML'.

I'll investigate this further, and if I can't get glade to do the translations
automatically, I'll set them manually in the source. 
(It could be because for some Tool Bar buttons I use 'stock' buttons for the
 images, but then set the labels to different non-stock values). 

I've also noticed some un-gettext-ized tooltip strings in the source, that 
are now gettext-ized and are in need of new translation; I've also fixed
an unrelated issue that resulted in line number changes in NamedConf.py,
and ZoneTree.py, so the translations need updating meanwhile, for the new
system-config-bind-4.0.0-42.FC6 version.
Comment 2 Ankit Patel 2006-08-02 00:52:24 EDT
Still, i couldn't find the strings which i mentioned in my first comment in any
of the .po files...
Comment 3 Ankit Patel 2006-09-12 06:33:11 EDT
Hi Martin,

Can you be able to extract the mentioned strings for translation?
Comment 4 Martin Stransky 2006-09-12 12:00:06 EDT
I've just added fix to CVS, it's package system-config-bind-4.0.1-2.fc6.noarch.rpm

It's here - http://people.redhat.com/stransky/bind/

Could you check it?
Comment 5 Ankit Patel 2006-09-13 00:51:49 EDT
(In reply to comment #4)
> I've just added fix to CVS, it's package system-config-bind-4.0.1-2.fc6.noarch.rpm
> 
> It's here - http://people.redhat.com/stransky/bind/
> 
> Could you check it?

I haven't got any updates in the .pot file !
Comment 6 Martin Stransky 2006-09-13 04:57:58 EDT
Sure, I didn't update pot files, I fixed a locale loading from glade template....
Comment 7 Ankit Patel 2006-09-18 09:11:03 EDT
I have checked the latest one (system-config-bind-4.0.1-2.fc6.noarch.rpm). It
seems that """Import, Preview, Manual..."""" are now extracted for translation &
i can see them in my native language (gu-IN).

Still, there is one string which i couldn't see extracted for translation, and
it's "TO DO". This message appears in the Help => About => Credits => Translator.

Can you please extract this one too, for translation?
Comment 8 Martin Stransky 2006-09-18 09:34:04 EDT
I don't think we need to translate the "TO DO" string :-)

Do you have any better idea what we should write to credits to the translators
section? "Fedora/RH translation team" or something like it?
Comment 9 Ankit Patel 2006-09-18 10:50:15 EDT
If we will follow what the gnome people follows it will be better.

Please open this link:
http://l10n-status.gnome.org/gnome-2.16/PO/gedit.HEAD.gu.po

It's gedit translation into Gujarati (gu-IN).

Please search for the word "translator-credits"

You will find the translation of that string as a translator's name in his/her
native language plus his/her e-mail ID.
Comment 10 Ankit Patel 2006-10-04 05:39:09 EDT
Ping.
Comment 11 Martin Stransky 2006-10-04 08:26:48 EDT
fixed in system-config-bind-4.0.1-3.fc6

Comment 12 Martin Stransky 2006-10-04 08:28:50 EDT
fixed in rawhide, packages for test are at
http://people.redhat.com/stransky/bind/test/
Comment 13 Ankit Patel 2006-10-05 05:00:04 EDT
Okay, i have tested it locally, it looks correct now. But, i still can't find
the "translator-credits" string exctracted for translation in translation CVS
repository...

Can you please make it available for translation in CVS?
Comment 14 Martin Stransky 2006-10-05 05:04:14 EDT
Sure, I'm gonna upload it to external CVS but I need to rework it a bit before.
Comment 15 Martin Stransky 2006-10-25 02:49:51 EDT
It shoul be available for translation in CVS now.
Comment 16 Ankit Patel 2006-11-14 02:32:56 EST
(In reply to comment #15)
> It shoul be available for translation in CVS now.

It's there, you can close/resolve this bug now...

Note You need to log in before you can comment on or make changes to this bug.