Bug 1950024 - Rebuild for Centos Stream and RHEL 8.4
Summary: Rebuild for Centos Stream and RHEL 8.4
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: gdal
Version: epel8
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: markusN
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-04-15 15:21 UTC by Eric Söderman
Modified: 2021-06-09 02:14 UTC (History)
15 users (show)

Fixed In Version: gdal-3.0.4-7.el8 gdal-3.0.4-8.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-06-09 02:14:21 UTC
Type: Bug


Attachments (Terms of Use)

Description Eric Söderman 2021-04-15 15:21:42 UTC
Description of problem:
I think gdal has to be rebuilt for Centos Stream and RHEL 8.4 as there are new poppler and libdap packages.

Version-Release number of selected component (if applicable):
gdal-3.0.4-5.el8.x86_64

How reproducible:
everytime

Steps to Reproduce:
# dnf install gdal



Actual results:
Error: 
 Problem: conflicting requests
  - nothing provides libpoppler.so.78()(64bit) needed by gdal-3.0.4-5.el8.x86_64
  - nothing provides libdap.so.25()(64bit) needed by gdal-3.0.4-5.el8.x86_64
  - nothing provides libdapclient.so.6()(64bit) needed by gdal-3.0.4-5.el8.x86_64
  - nothing provides libdapserver.so.7()(64bit) needed by gdal-3.0.4-5.el8.x86_64
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

Comment 1 markusN 2021-04-17 16:36:33 UTC
I tried to trigger a rebuild, but

$ git clone -n https://src.fedoraproject.org/rpms/gdal.git /var/lib/mock/epel8-build-26806406-3363359/root/chroot_tmpdir/scmroot/gdal
Cloning into '/var/lib/mock/epel8-build-26806406-3363359/root/chroot_tmpdir/scmroot/gdal'...
$ git reset --hard c2037d401f923b4c2a53782c20cd8de9f0425af0
fatal: Could not parse object 'c2037d401f923b4c2a53782c20cd8de9f0425af0'.

(see https://koji.fedoraproject.org/koji/taskinfo?taskID=66134419)

Does anyone else know how to do that properly?

Comment 2 markusN 2021-04-25 10:00:04 UTC
Does @smani have an idea how this works?

Comment 3 adam winberg 2021-05-18 09:33:08 UTC
Any progress on this? RHEL 8.4 will be out shortly...

Comment 4 Sandro Mani 2021-05-18 09:36:12 UTC
gdal is not shipped in the EPEL repo, this package comes from somewhere else.

Comment 5 Eric Söderman 2021-05-18 17:54:11 UTC
(In reply to Sandro Mani from comment #4)
> gdal is not shipped in the EPEL repo, this package comes from somewhere else.

Sorry, I dont understand this comment. 

This package was built (https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-53ddeb81a7) from repo (https://src.fedoraproject.org/rpms/gdal/tree/epel8) ?

Comment 6 Sandro Mani 2021-05-18 22:10:23 UTC
My mistake, I didn't have the epel8 branch locally and didn't immediately see epel8 koji builds and jumped to incorrect conclusions. I'll look into it.

Comment 7 Fedora Update System 2021-05-18 23:43:16 UTC
FEDORA-EPEL-2021-c056b5408f has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2021-c056b5408f

Comment 8 Fedora Update System 2021-05-19 01:48:07 UTC
FEDORA-EPEL-2021-c056b5408f has been pushed to the Fedora EPEL 8 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2021-c056b5408f

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 9 Eric Söderman 2021-05-19 09:12:54 UTC
Thanks, I tried it now in CentOS Stream installing from epel-testing, but same problem with lipoppler:

$ sudo dnf install gdal --enablerepo=epel-testing
Last metadata expiration check: 0:03:20 ago on Wed 19 May 2021 11:06:26 CEST.
Error: 
 Problem: cannot install the best candidate for the job
  - nothing provides libpoppler.so.78()(64bit) needed by gdal-3.0.4-7.el8.x86_64
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

It was an error by me when creating this bugzilla mentioning libdap (forgot to enable PowerTools repo) so it seems to only be a libpoppler dependency problem (libpoppler.so.104 now in RHEL 7.4 and Centos Stream).

Comment 10 Sandro Mani 2021-05-19 09:15:18 UTC
The EPEL buildroot currently has poppler-0.66.0-27.el8 , what poppler version do you have?

Comment 11 Eric Söderman 2021-05-19 09:20:49 UTC
On both Centos Stream and RHEL 7.4 it is poppler-20.11.0-2.el8.x86_64, so that explains it?

Comment 12 Eric Söderman 2021-05-19 09:28:16 UTC
Sorry, it should be 8.4 and not 7.4. :-)

Comment 13 Sandro Mani 2021-05-19 09:50:18 UTC
yep that's the issue... Not sure when and how poppler-20.11.0 will land in the EPEL buildroot.

Comment 14 Orion Poplawski 2021-05-30 19:08:11 UTC
poppler-20.11.0 has landed in the EPEL8 buildroot, see https://koji.fedoraproject.org/koji/taskinfo?taskID=69011778

Comment 15 Fedora Update System 2021-06-03 00:30:50 UTC
FEDORA-EPEL-2021-c056b5408f has been pushed to the Fedora EPEL 8 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 16 adam winberg 2021-06-04 05:29:52 UTC
The gdal package that was now pushed to EPEL8 stable is the faulty one, with dependency to the old libpoppler. 
Can a new version be built now that the new poppler version is in the buildroot?

Comment 17 Gabriele Pohl 2021-06-04 14:58:57 UTC
I can confirm that the problem still exists as I saw this today when I tried upgrading to CentOS8 2105:

# dnf update
Last metadata expiration check: 2:41:49 ago on Fri 04 Jun 2021 10:44:49 AM CEST.
Error:
 Problem 1: cannot install both poppler-20.11.0-2.el8.x86_64 and poppler-0.66.0-27.el8.x86_64
  - package gdal-3.0.4-7.el8.x86_64 requires libpoppler.so.78()(64bit), but none of the providers can be installed
  - cannot install the best update candidate for package poppler-0.66.0-27.el8.x86_64
  - cannot install the best update candidate for package gdal-3.0.4-5.el8.x86_64
 Problem 2: cannot install both poppler-20.11.0-2.el8.x86_64 and poppler-0.66.0-27.el8.x86_64
  - package gdal-libs-3.0.4-7.el8.x86_64 requires libpoppler.so.78()(64bit), but none of the providers can be installed
  - package cups-filters-1.20.0-24.el8.x86_64 requires libpoppler.so.104()(64bit), but none of the providers can be installed
  - cannot install the best update candidate for package gdal-libs-3.0.4-5.el8.x86_64
  - cannot install the best update candidate for package cups-filters-1.20.0-20.el8.x86_64
 Problem 3: cannot install both poppler-20.11.0-2.el8.x86_64 and poppler-0.66.0-27.el8.x86_64
  - package gdal-libs-3.0.4-7.el8.x86_64 requires libpoppler.so.78()(64bit), but none of the providers can be installed
  - package poppler-utils-20.11.0-2.el8.x86_64 requires libpoppler.so.104()(64bit), but none of the providers can be installed
  - package poppler-utils-20.11.0-2.el8.x86_64 requires poppler(x86-64) = 20.11.0-2.el8, but none of the providers can be installed
  - package gdal-devel-3.0.4-7.el8.x86_64 requires gdal-libs(x86-64) = 3.0.4-7.el8, but none of the providers can be installed
  - cannot install the best update candidate for package poppler-utils-0.66.0-27.el8.x86_64
  - cannot install the best update candidate for package gdal-devel-3.0.4-5.el8.x86_64
 Problem 4: problem with installed package gdal-libs-3.0.4-5.el8.x86_64
  - package gdal-libs-3.0.4-5.el8.x86_64 requires libpoppler.so.78()(64bit), but none of the providers can be installed
  - package gdal-libs-3.0.4-7.el8.x86_64 requires libpoppler.so.78()(64bit), but none of the providers can be installed
  - cannot install both poppler-20.11.0-2.el8.x86_64 and poppler-0.66.0-27.el8.x86_64
  - package texlive-pdftex-7:20180414-20.el8.x86_64 requires libpoppler.so.104()(64bit), but none of the providers can be installed
  - cannot install the best update candidate for package texlive-pdftex-7:20180414-19.el8.x86_64
 Problem 5: problem with installed package gdal-3.0.4-5.el8.x86_64
  - package gdal-3.0.4-5.el8.x86_64 requires libpoppler.so.78()(64bit), but none of the providers can be installed
  - package gdal-3.0.4-7.el8.x86_64 requires libpoppler.so.78()(64bit), but none of the providers can be installed
  - cannot install both poppler-20.11.0-2.el8.x86_64 and poppler-0.66.0-27.el8.x86_64
  - package texlive-xetex-7:20180414-20.el8.x86_64 requires libpoppler.so.104()(64bit), but none of the providers can be installed
  - cannot install the best update candidate for package texlive-xetex-7:20180414-19.el8.x86_64
 Problem 6: problem with installed package gdal-devel-3.0.4-5.el8.x86_64
  - package gdal-devel-3.0.4-5.el8.x86_64 requires gdal-libs(x86-64) = 3.0.4-5.el8, but none of the providers can be installed
  - package gdal-devel-3.0.4-7.el8.x86_64 requires gdal-libs(x86-64) = 3.0.4-7.el8, but none of the providers can be installed
  - package gdal-libs-3.0.4-5.el8.x86_64 requires libpoppler.so.78()(64bit), but none of the providers can be installed
  - package gdal-libs-3.0.4-7.el8.x86_64 requires libpoppler.so.78()(64bit), but none of the providers can be installed
  - cannot install both poppler-20.11.0-2.el8.x86_64 and poppler-0.66.0-27.el8.x86_64
  - package cups-filters-1.20.0-24.el8.x86_64 requires libpoppler.so.104()(64bit), but none of the providers can be installed
  - package cups-1:2.2.6-38.el8.x86_64 requires cups-filters, but none of the providers can be installed
  - package cups-filters-1.20.0-20.el8.x86_64 requires cups-filters-libs(x86-64) = 1.20.0-20.el8, but none of the providers can be installed
  - cannot install both cups-filters-libs-1.20.0-24.el8.x86_64 and cups-filters-libs-1.20.0-20.el8.x86_64
  - cannot install the best update candidate for package cups-filters-libs-1.20.0-20.el8.x86_64
  - cannot install the best update candidate for package cups-1:2.2.6-38.el8.x86_64
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

Comment 18 Fedora Update System 2021-06-07 14:43:49 UTC
FEDORA-EPEL-2021-c350944578 has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2021-c350944578

Comment 19 Fedora Update System 2021-06-08 01:41:40 UTC
FEDORA-EPEL-2021-c350944578 has been pushed to the Fedora EPEL 8 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2021-c350944578

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 20 Fedora Update System 2021-06-09 02:14:21 UTC
FEDORA-EPEL-2021-c350944578 has been pushed to the Fedora EPEL 8 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.