Bug 195009 - X crashed: error in I830WaitLpRing()
X crashed: error in I830WaitLpRing()
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-14 09:22 EDT by James
Modified: 2008-08-02 19:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-14 19:07:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg logfile showing the problem (65.13 KB, text/plain)
2006-06-14 09:22 EDT, James
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 4353 None None None Never

  None (edit)
Description James 2006-06-14 09:22:50 EDT
Description of problem:
X.org crashed with an error in I830WaitLpRing() (see attached log file). It also
appeared to take out i915 DRM in the kernel, as the X server could not restart
and I had to reboot the notebook. Happened when running a GL app (Google Earth
for Linux), and has been seen before when running Xine. I'm using an Intel i855
graphics adapter.

Version-Release number of selected component (if applicable):
xorg-x11-6.8.2-37.FC4.49.2.1
kernel-2.6.16-1.2115_FC4

How reproducible:
Sporadic

Steps to Reproduce:
1. Run an application which triggers it.
  
Actual results:
X locks up. Cannot switch to text-mode console. Display is completely broken.
Have to reboot with Ctrl+Alt+Del. Following is in the X.org log file:

Error in I830WaitLpRing(), now is 5188, start is 3187
pgetbl_ctl: 0x1ffe0001 pgetbl_err: 0x0
ipeir: 0 iphdr: 68200966
LP ring tail: c8 head: 0 len: 1f001 start 0
eir: 0 esr: 0 emr: ffff
instdone: efc1 instpm: 0
memmode: 108 instps: 50
hwstam: ffff ier: 82 imr: 9 iir: 20
space: 130864 wanted 131064
(II) I810(0): [drm] removed 1 reserved context for kernel
(II) I810(0): [drm] unmapping 8192 bytes of SAREA 0xdebf9000 at 0xb7e4a000

Fatal server error:
lockup

Expected results:
No lockups!

Additional info:
The following system log extract:

Jun 13 18:00:24 localhost kernel: [drm:i915_wait_irq] *ERROR* i915_wait_irq:
EBUSY -- rec: 680226 emitted: 680230
Jun 13 18:00:29 localhost dbus: avc:  1 AV entries and 1/512 buckets used,
longest chain length 1 
Jun 13 18:00:30 localhost gdm[2709]: gdm_slave_xioerror_handler: Fatal X error -
Restarting :0
Jun 13 18:00:30 localhost gdm(pam_unix)[2709]: session closed for user james
Jun 13 18:00:30 localhost gconfd (james-2863): Received signal 15, shutting down
cleanly
Jun 13 18:00:31 localhost gconfd (james-2863): Exiting
Jun 13 18:00:53 localhost gpm[2340]: *** info [mice.c(1766)]: 
Jun 13 18:00:53 localhost gpm[2340]: imps2: Auto-detected intellimouse PS/2
Jun 13 18:01:18 localhost gdm[14028]: failsafe dialog failed (inhibitions: 0 0)
Jun 13 18:01:37 localhost gdm[14219]: failsafe dialog failed (inhibitions: 0 0)
Jun 13 18:01:49 localhost gpm[2340]: *** info [mice.c(1766)]: 
Jun 13 18:01:49 localhost gpm[2340]: imps2: Auto-detected intellimouse PS/2
Jun 13 18:01:49 localhost gpm[2340]: *** info [client.c(137)]: 
Jun 13 18:01:49 localhost gpm[2340]: Connecting at fd 6
Jun 13 18:02:08 localhost shutdown: shutting down for system reboot
Jun 13 18:02:08 localhost init: Switching to runlevel: 6
Comment 1 James 2006-06-14 09:22:50 EDT
Created attachment 130844 [details]
Xorg logfile showing the problem
Comment 2 Mike A. Harris 2006-06-14 18:03:16 EDT
Please upgrade to Fedora Core 5, and indicate if the problem still occurs.
Comment 3 James 2006-06-14 19:07:47 EDT
OK, I'll do that this weekend. Since this problem has a
mean-time-between-surfacing of order months, I probably won't have anything to
report for a while (so you can decide how best to sleep this bug). If I see it
under FC5, I'll file a new bug under xorg-x11-drv-i810.

Note You need to log in before you can comment on or make changes to this bug.