Bug 1950593 - Can't properly upload image to Storage Domain without using Test Connection button
Summary: Can't properly upload image to Storage Domain without using Test Connection b...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage
Version: 4.4.5.11
Hardware: x86_64
OS: Linux
unspecified
medium vote
Target Milestone: ovirt-4.4.7
: ---
Assignee: Bella Khizgiyaev
QA Contact: Amit Sharir
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-04-17 04:25 UTC by Nur Imam Febrianto
Modified: 2021-07-06 07:28 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-07-06 07:28:24 UTC
oVirt Team: Storage
pm-rhel: ovirt-4.4+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 115262 0 master MERGED webadmin: imageIO session isn't opened when uploading an image from UI 2021-06-23 14:23:26 UTC
oVirt gerrit 115466 0 master MERGED webadmin: fix resume image upload from UI 2021-06-29 16:19:16 UTC

Description Nur Imam Febrianto 2021-04-17 04:25:31 UTC
Description of problem:
Can't upload any ISO/Image into Storage Domain without using Test Connection button after upgrading to 4.4.5 from 4.4.4

Version-Release number of selected component (if applicable):
oVirt Engine 4.4.5.11

How reproducible:
100

Steps to Reproduce:
1. Open any storage domain
2. Open Disk tab
3. Click Upload
4. Choose any ISO/Image
5. Start upload

Actual results:
The image that means to be uploaded is shows "OK" status without any upload progress, even if it was huge image.

Expected results:
After clicking start upload, usually it shows "Locked" status and then continued with Upload progress until the imaage is successfully transferred to the storage.

Additional info:
This issue wont happen, if i click "Test Connection" button first before start uploading. Another finding, seems if i don't click "Test Connection" button, the engine doesn't open any session to imageio. If i click test connection, it open a session in imageio so the upload can be done successfully (found this while tail-ing imageio logs)

Comment 1 RHEL Program Management 2021-04-19 14:24:33 UTC
The documentation text flag should only be set after 'doc text' field is provided. Please provide the documentation text and set the flag to '?' again.

Comment 2 Nur Imam Febrianto 2021-06-01 17:20:06 UTC
I can confirm this issue still happened in 4.4.6.

Comment 3 Bella Khizgiyaev 2021-06-16 06:14:22 UTC
After looking in the logs the imageio session is not opened for the upload in the current implementation.
using the Ontest() before the uploaded established a session and checks the connection to ovirt-imageio service.

steps to reproduce:
1. Open any storage domain
2. Open Disk tab
3. Click Upload
4. Choose any ISO/Image
5. Start upload

result:
the disk will be locked at first and then the disk upload will be issued to the system (progress will be shown).

Comment 4 Bella Khizgiyaev 2021-06-30 06:15:31 UTC
When verifying also need to make sure that the resume upload operation is working right from the UI.

Comment 5 Amit Sharir 2021-07-04 09:35:53 UTC
Version:
ovirt-engine-4.4.7.6-0.11.el8ev.noarch
rhv-release-4.4.7-6-001.noarch
redhat-release-8.4-0.6.el8.x86_64
redhat-release-eula-8.4-0.6.el8.x86_64

Verification conclusions:
I completed the whole flow mentioned above including checking that I can pause/resume the upload from the UI.
I was able to monitor the progress of the upload progress from the UI until it finished uploading the disk (appears in the UI as "complete") 
The expected output matched the actual output.


Bug verified.

Comment 6 Sandro Bonazzola 2021-07-06 07:28:24 UTC
This bugzilla is included in oVirt 4.4.7 release, published on July 6th 2021.

Since the problem described in this bug report should be resolved in oVirt 4.4.7 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.