Bug 19511 - LINUX 6.2 FAILS TO EXECUTE ON ATHLON PROCESSOR
LINUX 6.2 FAILS TO EXECUTE ON ATHLON PROCESSOR
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.2
All Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-21 12:33 EDT by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-27 18:10:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-10-21 12:33:46 EDT
Hello there!,
    I have been trying to install RED HAT 6.2. Installation completes and while LINUX attempts to complete a reboot-causes the process to 
hang 
with the readout below. Several users on the RED HAT DISCUSSION GROUPS have the same problem We all have an ATHLON 
PROCESSOR. Mine is a 750mhz screamer built by GATEWAY. Any suggestions????????
yours,
Steve z

--------------------------------------------------------------------------------------------------------------------------------------------------
Memory : 127788K / 130944K available (1060K kernel code, 416K reserved, 1616K data, 
64K init, 0K big mem) 
Dentry hash table entries : 262144 (order 9, 2048K) 
Buffer cache hash table entries : 131072 (order 7, 512K) 
Page cache hash table entries : 32768 (order 5, 128K) 
VFS : Disk quotas version dquot_6.4.0 initialised 
L1 Icache 64K  L1 Dcache 64K 
L2 Cache : 1K 
CPU AMD AMD Athlon(tm) Processor stepping 00 
Enabling extended fast FPU save and restore....done 
Disabling CPUID serial number.....general protection fault : 0000 
CPU : 0 
EIP : 0010 [<c02340f4>] 
EFLAGS : 00010282 
eax:00000020  ebx:07c2d454  ecx:00000119  edx:00000001 
esi:00098800  edi:c0106000  ebp:000007be  esp:c0233fc8 
ds:0018  es:0018  ss:0018 
Process swapper (pid=0, process nr:0, stackpage=c0233000) 
Stack : c0106000  c02344e2  c02143a0  c01d7d0b  c02143a0 
        c0234c7b  07c2d454  07c2d454  07c2d454  c03b2bac 
        c7fe0000  00000000  c0214460  c0100175 
Call trace : [<c0106000>] [<c01d7d0b>] [<c0100175>] 
Code : 0f 32 0d 00 00 20 00 0f 30 68 21 78 1d c0 e8 27 fd ed ff 83 
Kernel panic : attempted to kill the idle task ! 
In swapper task - not syncing
Comment 1 amitabha 2000-10-26 18:11:32 EDT
 This seems to be a bug with the kernel trying to 
disable the CPU ID number which causes it to panic
on Athlons.

A way to resolve it is to type the following
at the LILO prompt:

LILO: linux x86_serial_nr=1

Another solution is: once the above solution gets
you into the system , use linuxconf to add that parameter
to lilo so that you don't have to type it in everytime.

Third solution: recompile kernel.
Comment 2 amitabha 2000-10-26 18:12:18 EDT
 This seems to be a bug with the kernel trying to 
disable the CPU ID number which causes it to panic
on Athlons.

A way to resolve it is to type the following
at the LILO prompt:

LILO: linux x86_serial_nr=1

Another solution is: once the above solution gets
you into the system , use linuxconf to add that parameter
to lilo so that you don't have to type it in everytime.

Third solution: recompile kernel.
Comment 3 Michael Fulbright 2000-10-27 18:10:22 EDT
This information is correct as to how to workaround the problem.

Note You need to log in before you can comment on or make changes to this bug.