Bug 1951894 - Add validation when creating storage domain with disperse volume type
Summary: Add validation when creating storage domain with disperse volume type
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Gluster
Version: 4.4.5.1
Hardware: All
OS: All
low
low vote
Target Milestone: ovirt-4.4.7
: 4.4.7.3
Assignee: Ritesh Chikatwar
QA Contact: SATHEESARAN
URL:
Whiteboard:
Depends On:
Blocks: 1951895
TreeView+ depends on / blocked
 
Reported: 2021-04-21 06:48 UTC by Ritesh Chikatwar
Modified: 2021-07-06 07:27 UTC (History)
2 users (show)

Fixed In Version: ovirt-engine-4.4.7.3
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1951895 (view as bug list)
Environment:
Last Closed: 2021-07-06 07:27:54 UTC
oVirt Team: Gluster
pm-rhel: ovirt-4.4+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 114399 0 master MERGED core: Added validation to check for unsupported volume type 2021-06-06 11:16:43 UTC

Description Ritesh Chikatwar 2021-04-21 06:48:02 UTC
Description of problem:
When creating storage domain it should fail for unsupported volume type.

Version-Release number of selected component (if applicable):
4.4.4


How reproducible:


Steps to Reproduce:
1. Login to administration portal
2. Navigate to Storage -> Domain -> New 
3. Select gluster type & disperse volume and submit

Actual results:
Storage Domain created.

Expected results:
It should fail as disperse volume is not supported

Additional info:

Comment 1 SATHEESARAN 2021-05-04 00:29:55 UTC
As discussed in the last hyperconverged engineering team meeting, this bug is not a blocker for ovirt-4.4.6
but this will prevent users from using disperse volume for ovirt storage domains, which will be good preventive check.

This check will be targeted for ovirt-4.4.7

Comment 2 SATHEESARAN 2021-06-21 07:28:11 UTC
Tested with 4.4.7.4-0.9.el8ev

On the hyperconverged virt + gluster cluster, created a new gluster volume of type disperse from command line interface.
Tried to create a new storage domain with this gluster disperse volume and that failed with the warning:
"Error while executing action: Unsupported Gluster volume type, volume: disperse, volume type: DISPERSE. Please use the replicate type. To recover existing, migrate it to the supported type."

Comment 3 Sandro Bonazzola 2021-07-06 07:27:54 UTC
This bugzilla is included in oVirt 4.4.7 release, published on July 6th 2021.

Since the problem described in this bug report should be resolved in oVirt 4.4.7 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.